Author Topic: Firewall does not show alerts in Safe Mode  (Read 1012 times)

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Firewall does not show alerts in Safe Mode
« on: November 16, 2021, 08:03:27 AM »
Version: 12.2.2.8012 (Windows 7)

I have installed new apps recently that use internet connection.
I noticed firewall did not show alerts for any of them!
Also there were no HIPS alerts.

Important options in Firewall Settings:
Do not show popup alerts is UNCHECKED
Create rules for safe applications is UNCHECKED
Set alert frequency level is UNCHECKED

Important options in HIPS Settings:
Do not show popup alerts is UNCHECKED
Create rules for safe applications is UNCHECKED

Also in Firewall application rules there were only couple of applications and some "generic" like:
system
comodo internet security
windows updater applications
windows system applications

I removed all rules and restarted computer.

It did not help. Still no alerts...

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 5324
Re: Firewall does not show alerts in Safe Mode
« Reply #1 on: November 16, 2021, 08:37:04 AM »
It is by design, your not supposed the get alerts from trusted applications, only those with an unrecognized rating will trigger alerts.

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Re: Firewall does not show alerts in Safe Mode
« Reply #2 on: November 16, 2021, 08:56:17 AM »
Where I can read more about this "trust" classification?
Also as a user I would like to have possibility to block internet access even for "trusted" applications :)
Trust is not 100% objective term. Someone can trust one application and other might not. And they are both "right".

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 5324
Re: Firewall does not show alerts in Safe Mode
« Reply #3 on: November 16, 2021, 09:02:53 AM »
Read the help documentation, for starters the file rating section and the unknow file scanning process. You can also just change the firewall mode to custom-ruleset mode.

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Re: Firewall does not show alerts in Safe Mode
« Reply #4 on: November 16, 2021, 09:16:53 AM »
Thank you very much!
I have read it and it was ... calming :)
Still, please consider at least some log, so we can review what apps were granted access.
Currently Firewall Log Events is empty.
There is Connection View but it's only snapshot at given time.

Offline domo78

  • Comodo's Hero
  • *****
  • Posts: 354
Re: Firewall does not show alerts in Safe Mode
« Reply #5 on: November 16, 2021, 10:04:13 AM »

Important options in Firewall Settings:
Do not show popup alerts is UNCHECKED
Create rules for safe applications is UNCHECKED
Set alert frequency level is UNCHECKED

Important options in HIPS Settings:
Do not show popup alerts is UNCHECKED
Create rules for safe applications is UNCHECKED


as a reminder:
https://help.comodo.com/topic-72-1-766-9172-General-Firewall-Settings.html

On my laptop:
- Do not show popup alerts is UNCHECKED
- Create rules for safe applications is Checked (this is necessary if you want application rules to be created in "Safe Mode" by Comodo FW)
- Set alert frequency level is High

You can then apply to each "application rules " a "Firewall Rule Sets"

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Re: Firewall does not show alerts in Safe Mode
« Reply #6 on: November 16, 2021, 10:35:43 AM »
Hi domo78 :)

I read in different topics that
Create rules for safe applications
is buggy and should not be used.

I set temporarily "Alert frequency" to "Very High" and still no alerts were presented.

Offline domo78

  • Comodo's Hero
  • *****
  • Posts: 354
Re: Firewall does not show alerts in Safe Mode
« Reply #7 on: November 16, 2021, 10:40:20 AM »
Hi domo78 :)

I read in different topics that
Create rules for safe applications
is buggy and should not be used.

I set temporarily "Alert frequency" to "Very High" and still no alerts were presented.

It is buggy in HIPS not in the FW

Offline ZorKas

  • Comodo's Hero
  • *****
  • Posts: 2175
Re: Firewall does not show alerts in Safe Mode
« Reply #8 on: November 16, 2021, 12:30:05 PM »
You are on the right network ?

Windows 10 Pro x64 21H2 Build 19044.1706 - Windows 11 Pro x64 21H2 Build 22000.675 - Linux Emmabuntüs x64 ED4 - Comodo CIS Pro v.12.2.2.8012 - Moderator French Comodo

Offline CISfan

  • Comodo's Hero
  • *****
  • Posts: 1889
Re: Firewall does not show alerts in Safe Mode
« Reply #9 on: November 16, 2021, 02:06:00 PM »
Maybe an active VPN connection bypasses CIS Firewall.

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Re: Firewall does not show alerts in Safe Mode
« Reply #10 on: November 18, 2021, 10:15:06 AM »
I do not use VPN.

Anyways, I checked create rules for safe applications and all apps were added :)
So at least I now see what was/is allowed to connect :)

Thank you! :)

Offline domo78

  • Comodo's Hero
  • *****
  • Posts: 354
Re: Firewall does not show alerts in Safe Mode
« Reply #11 on: November 18, 2021, 04:40:57 PM »
Anyways, I checked create rules for safe applications and all apps were added
So at least I now see what was/is allowed to connect

Good news.
If you wish you can then apply to each "application rule" a "Firewall Rule Set" (Web browser, Email client, ...) by adapting it to your needs.

Offline PiotrM

  • Newbie
  • *
  • Posts: 15
Re: Firewall does not show alerts in Safe Mode
« Reply #12 on: November 19, 2021, 04:59:47 AM »
I already blocked some applications :)

Couple of months I had some issues with HIPS,
and then I disabled "create rules for safe apps" for both HIPS & firewall.
I must have misunderstand that it was general problem, not HIPS only issue.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek