Author Topic: Firewall blocks incoming OSC connections  (Read 471 times)

Offline Vivicector

  • Newbie
  • *
  • Posts: 10
Firewall blocks incoming OSC connections
« on: November 24, 2021, 06:06:38 AM »
Hi! I have an issue with firewall blocking incomming UDP connection. I have facetracker on my phone that sends data packets to a specific port on my PC via Open Sound Control protocol. Several packets per second.
Firewall blocks that and lists that as network intrusions. I have rules with very high alert, warn me on incoming connections and also global to allow everything inside local network. But those incoming connections get blocked without any warnings at all. Never a single request.
How do I solve that issue and allow them?

The logs are as follows: https://imgur.com/a/B0QuT0y

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Moderator
  • Comodo's Hero
  • *****
  • Posts: 703
Re: Firewall blocks incoming OSC connections
« Reply #1 on: November 24, 2021, 07:25:01 AM »
Hi Vivicector,

Thank you for reporting, we will check and get back to you.
May i know your:
1. CIS/CFW version ?
2. Win version and System type(32bit/64bit) ?
3. Is there any other security product installed on your machine?
4. Any other information, eg your guess at the cause, how you tried to fix it etc.
5. If possible, any related screenshots.

Thanks
C.O.M.O.D.O RT

Offline Vivicector

  • Newbie
  • *
  • Posts: 10
Re: Firewall blocks incoming OSC connections
« Reply #2 on: November 24, 2021, 07:57:25 AM »
Thanks!

1. CIS 12.2.2.8012
2. Win10 Ent x64 21H1, Windows Feature Experience Pack 120.2212.3920.0, 19043.1348
3. Nope. Windows Defender is disabled, Win Firewall is disabled but service is running.
4. I have tried settings to max alerts, I have created a rule to allow incoming to the port I need.
« Last Edit: November 24, 2021, 08:04:38 AM by Vivicector »

Offline C.O.M.O.D.O RT

  • Comodo Staff
  • Moderator
  • Comodo's Hero
  • *****
  • Posts: 703
Re: Firewall blocks incoming OSC connections
« Reply #3 on: November 24, 2021, 09:30:56 AM »
Thanks!

1. CIS 12.2.2.8012
2. Win10 Ent x64 21H1, Windows Feature Experience Pack 120.2212.3920.0, 19043.1348
3. Nope. Windows Defender is disabled, Win Firewall is disabled but service is running.
4. I have tried settings to max alerts, I have created a rule to allow incoming to the port I need.
Hi Vivicector,

Thank you for providing the information, we will check and update you.

Thanks
C.O.M.O.D.O RT

Offline Vivicector

  • Newbie
  • *
  • Posts: 10
Re: Firewall blocks incoming OSC connections
« Reply #4 on: November 24, 2021, 11:29:56 AM »
Ok, fixed that by allowing connections to said port for Windows Operating System, since the logs mentioned it. Weird that simply making a global rule to allow for connections to this port didn't work. RDP access was quite easy to add this way. Also weird that system never asked me if I allow inbound connection too. May be it fit some of those prebuilt rules for system...

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 5324
Re: Firewall blocks incoming OSC connections
« Reply #5 on: November 24, 2021, 11:52:25 AM »
Your supposed to add the application that is running and listening on the port to receive the connection requests. The firewall won't alert for it if the application has a trusted rating. If it runs as a windows service that is hosted within svchost then you would create the allow incoming rule for svchost.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek