Author Topic: Comodo Firewall blocking Windows 10 "Project" function  (Read 386 times)

Offline Arcane3

  • Newbie
  • *
  • Posts: 2
Comodo Firewall blocking Windows 10 "Project" function
« on: December 23, 2018, 05:20:19 PM »
Hi all, I have looked around the forum briefly to try and find a similar post but I cannot.

I have recently bought an LG smart TV which has "Screen Share" in it. I'm running Windows 10. In the bottom right I can click on the speech bubble and click "Project" to then project my laptop screen to the TV.

The issue I am having is this only works if the Comodo firewall is turned off. I have browsed through settings to try and find a way to let it through but I can't find anything.

Thanks in advance for any help you can offer.

Offline Metheni

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 592
Re: Comodo Firewall blocking Windows 10 "Project" function
« Reply #1 on: December 24, 2018, 06:22:20 AM »
Hi Arcane3,

Welcome to Comodo Forum.

Thanks for reporting.
Could you please check your Inbox for private message and provide the requested logs.

Thanks,
Metheni R

Hi all, I have looked around the forum briefly to try and find a similar post but I cannot.

I have recently bought an LG smart TV which has "Screen Share" in it. I'm running Windows 10. In the bottom right I can click on the speech bubble and click "Project" to then project my laptop screen to the TV.

The issue I am having is this only works if the Comodo firewall is turned off. I have browsed through settings to try and find a way to let it through but I can't find anything.

Thanks in advance for any help you can offer.

Offline Metheni

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 592
Re: Comodo Firewall blocking Windows 10 "Project" function
« Reply #2 on: December 26, 2018, 06:54:05 AM »
Hi Arcane3,

Thank you for providing the requested logs. We're working On it.

Regards,
Metheni R

Offline Arcane3

  • Newbie
  • *
  • Posts: 2
Re: Comodo Firewall blocking Windows 10 "Project" function
« Reply #3 on: January 13, 2019, 02:57:46 AM »
Hi there,

Has there been any update to this? I still cannot get Project to function when Comodo firewall is turned on.

No matter what settings I have looked through and the amount of Google searches I've done, nothing seems to help.

Thanks.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 3943
Re: Comodo Firewall blocking Windows 10 "Project" function
« Reply #4 on: January 13, 2019, 09:42:52 AM »
Hi all, I have looked around the forum briefly to try and find a similar post but I cannot.

I have recently bought an LG smart TV which has "Screen Share" in it. I'm running Windows 10. In the bottom right I can click on the speech bubble and click "Project" to then project my laptop screen to the TV.

The issue I am having is this only works if the Comodo firewall is turned off. I have browsed through settings to try and find a way to let it through but I can't find anything.

Thanks in advance for any help you can offer.
Try to add a firewall application rule for svchost.exe and set it with the allowed application ruleset. I'm assuming you have also set your network to home and it is trusted in manage network task? If it still doesn't work then you should collect packet captures using wireshark.

1. Go to https://www.wireshark.org/#download
2.Set Comodo firewall to disabled and launch wireshark.
3.Double-click on your active network adapter and then begin to use the projection function.
4.When projection successfully completes stop capture and save it with firewall disabled as the file name.
5.Repeat steps but with the firewall enabled and keep capture running until projection fails. Then stop and save packet capture with firewall enabled file name.
6.Provide those packet captures for investigation.
« Last Edit: January 13, 2019, 09:50:39 AM by futuretech »

Offline da.petkov

  • Newbie
  • *
  • Posts: 1
Re: Comodo Firewall blocking Windows 10 "Project" function
« Reply #5 on: January 24, 2019, 08:04:34 AM »
I can confirm, no matter what I add/allow in CIS settings, Comodo Firewall keeps blocking my PC from projecting on my LG TV. The only way it works is when I disable Comodo Firewall. Chromecast works though but I prefer Miracast/Screen Share.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek