Author Topic: comodo blocking port 80  (Read 613 times)

Offline empleat

  • Newbie
  • *
  • Posts: 9
comodo blocking port 80
« on: November 29, 2018, 12:27:00 PM »
Hello,
i am using comodo firewall 10 and it is blocking my port 80, which is kinda strange it is basic port and it is in port ruleset already.
I have port forwarding set in router and it is blocking various ports, checked with netstat and my game is using other ports than i forwarded.

I have set firewall safe mode.
I am using port checker application and i allowed it in comodo firewall and set it to: "allow all requests".
When i disable comodo firewall it works and says port 80, or another is open.
Any idea why comodo firewall blocking ports ? I didn't find anything in settings.
And googled that port rulesets, which i already have 80 by default and it stil blocks it.
Thanks for help.

Offline panic

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 11703
  • Linux is free only if your time is worthless.;-)
Re: comodo blocking port 80
« Reply #1 on: November 29, 2018, 04:50:17 PM »
Assuming that you are running a server of some sort that uses port 80 for inbound requests, you will need to make a GLOBAL rule to allow unsolicited inbound  requests to port 80.

1. Open CIS
2. Click SETTINGS
3. Click FIREWALL -> GLOBAL RULES
4. Click ADD
5. Create a rule with the following parameters;
     Action : ALLOW
     Protocol : TCP or UDP (You may only require TCP - this depends on the nature of the servers connenction)
     Direction : IN OR OUT
     Description : GIVE THE RULE A MEANINGFUL NAME
     Source Address : ANY ADDRESS
     Destination Address : ANY ADDRESS (or a specific address if you have assigned a static IP address to your server)
     Source Port : ANY
     Destination Port : 80
6. Click OK
7. Ensure that this new rule is above any BLOCK rule that could prevent it being executed
8. Click OK.

Hope this helps,
Ewen :-)
As your mums would say, "If you can't play nice with all the other kiddies, go home".
All users are asked to please read and abide by the  Comodo Forum Policy.
If you can't conform, don't use the forum.

Offline empleat

  • Newbie
  • *
  • Posts: 9
Re: comodo blocking port 80
« Reply #2 on: December 01, 2018, 06:41:44 PM »
Sadly this didn't help and i put that rule above all block rules.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4095
Re: comodo blocking port 80
« Reply #3 on: December 02, 2018, 11:51:15 AM »
Sadly this didn't help and i put that rule above all block rules.
Then you didn't set up port forward correctly or the rules for the application you are attempting to allow inbound access to. Check the firewall event logs to see any block events for port 80, also try disabling block fragmented IP traffic in firewall settings.

Offline empleat

  • Newbie
  • *
  • Posts: 9
Re: comodo blocking port 80
« Reply #4 on: December 02, 2018, 03:14:36 PM »
Rule is correct i checked, i have it set exactly same as panic posted. Block fragmented is disabled. Under firewall events is only asked, not blocked.
I am using port checker to check if ports are open, it still says: your ports are closed. And i have allowed it in firewall.
When i am playing game which use port 1119 for example. In netstat, i have local port like 2803.
I thought when i am forwarding ports, i am enabling this ports on my end so they are open.
And i saw also other ports which was changing in pairs, like 1119 and 1120, they constantly changed for host and destination address.
Shouldn't my local ports be also 1119 or 1120, instead of 2803 or something and port 1119 on destination address ?
I don't think that program doesn't work, it from portforwarding site https://portforward.com/ so it is probably still blocked.

Offline futuretech

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 4095
Re: comodo blocking port 80
« Reply #5 on: December 02, 2018, 08:28:09 PM »
What are you trying to accomplish? Why are you trying to make port 80 open from the outside? If you are not running a server for others to connect to you don't need to open ports. Also even if you set up rules to open a port in CIS and you have port forwarding enabled on your router, CIS will still stealth/block the port if no application is listening on the port.

Offline empleat

  • Newbie
  • *
  • Posts: 9
Re: comodo blocking port 80
« Reply #6 on: December 03, 2018, 10:26:30 AM »
Did you read my last message. As i said for example port 1119 and i said various ports too.
Comodo is blocking ports which are needed for games.
I need these ports to be accessible.
EDIT: sorry it works, i by mistake entered ports to source instead of destination, because i have headache.
« Last Edit: December 03, 2018, 11:10:42 AM by empleat »

Offline panic

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 11703
  • Linux is free only if your time is worthless.;-)
Re: comodo blocking port 80
« Reply #7 on: December 03, 2018, 05:50:44 PM »
Did you read my last message. As i said for example port 1119 and i said various ports too.
Comodo is blocking ports which are needed for games.
I need these ports to be accessible.
EDIT: sorry it works, i by mistake entered ports to source instead of destination, because i have headache.

Apology accepted.  ;) >:-D
As your mums would say, "If you can't play nice with all the other kiddies, go home".
All users are asked to please read and abide by the  Comodo Forum Policy.
If you can't conform, don't use the forum.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek