Author Topic: Deployment Error. Unknown Error  (Read 32654 times)

Offline w-e-v

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 1503
  • BETA FORCE MEMBER
Deployment Error. Unknown Error
« on: January 11, 2012, 03:45:01 PM »
Hello:

Im trying to install ESM 2.0 in a PC that is running Windows XP Pro.
Originally it was running Windows XP Home, but due to the same "Unknown Error" we fresh-installed Windows XP Professional. However, the same error is happening.

After installing ESM 2.0, we do the procedure to deploy CIS but we receive a message: Deployment Error

Looking at the error message details, we find this:
Code: [Select]
Deployment Failed
Unknown Error

Falta la red o bien no se ha iniciado.
Status_error (1222)

This is very strange. What are we doing wrong?


This morning, ESM started to act funny.
We always get disconnected from the service and it log us out automatically from the console.


Why cant we deploy CIS into the endpoints from the console?
Why do we get disconnected so often from the console?

Offline Tim B.

  • CESMUser
  • Newbie
  • *
  • Posts: 17
Re: Deployment Error. Unknown Error
« Reply #1 on: January 13, 2012, 08:33:02 AM »
Thank you for this post. About 1222 error. One of possible reasons is that network sharing is turned off on the remote PC. Have you tried accessing \\targetendpoint\admin$ share from ESM server machine? Could you check please?

Offline Tim B.

  • CESMUser
  • Newbie
  • *
  • Posts: 17
Re: Deployment Error. Unknown Error
« Reply #2 on: January 13, 2012, 09:22:08 AM »
Quote
This morning, ESM started to act funny.
We always get disconnected from the service and it log us out automatically from the console.

Could you please look through the recent ESM logs (available at ESM Configuration Tool -> Event Log) and find some errors. You can copy error log items and paste them here. Thanks!

Offline w-e-v

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 1503
  • BETA FORCE MEMBER
Re: Deployment Error. Unknown Error
« Reply #3 on: January 13, 2012, 02:34:17 PM »
Thank you for this post. About 1222 error. One of possible reasons is that network sharing is turned off on the remote PC. Have you tried accessing \\targetendpoint\admin$ share from ESM server machine? Could you check please?

Hello Tim,

One of the "remote PC" its the ESM SERVER itself.
When we try to install CIS in the same ESM SERVER, we also get the same "Deployment error (1222)".
Why do we get the same 1222 error if the installation FROM the server TO the server its not done through the network, but locally?


Either way, I have tried from ESM server machine accesing \\targetendpoints\admin$ and this are the results:

FROM ESM SERVER TO ESM SERVER (192.x.x.106) - Windows XP Pro
Command executed: \\192.168.10.106\admin$
Result: The network path was not found

FROM ESM SERVER TO ENDPOINT #1 (192.x.x.107) - Windows 7 Pro
Command executed: \\192.168.10.107\admin$
Result: Access denied

FROM ESM SERVER TO ENDPOINT #2 (192.x.x.116) - Windows XP Home
Command executed: \\192.168.10.116\admin$
Result: The network path was not found

What could be wrong?

Offline shan77

  • Newbie
  • *
  • Posts: 18
Re: Deployment Error. Unknown Error
« Reply #4 on: January 16, 2012, 02:31:58 AM »
Good morning!

I puchased this product:
"Comodo Endpoint Security Manager V2.0 Business Edition Console-100 Annual (100 - 100 endpoints)"
Can it hadle the free CIS?

I've got the same issue as w-e-v  (error code: 1222)
File sharing is enabled on target machines, also 9901 port in windows firewall, there are no other firewall soft. installed. I've no idea what to do...

Offline alex_gubernsky

  • CESMUser
  • Newbie
  • *
  • Posts: 12
Re: Deployment Error. Unknown Error
« Reply #5 on: January 16, 2012, 05:54:46 AM »
Quote
I puchased this product:
"Comodo Endpoint Security Manager V2.0 Business Edition Console-100 Annual (100 - 100 endpoints)"
Can it hadle the free CIS?

Hi Shan,

Cound you look at the "License Information" screen (About->License Information) and tell what information is in the following fields for the license you purchased:

  • Description
  • License type
  • License status
  • Products

This might help to figure out the reason of the problem.

Offline shan77

  • Newbie
  • *
  • Posts: 18
Re: Deployment Error. Unknown Error
« Reply #6 on: January 16, 2012, 06:27:50 AM »
Hi Alex!

  • Description: production purpose
  • License type: Normal
  • Lic. status: Valid
  • Products: livePCsupport

thx, for trying to help me..
« Last Edit: January 16, 2012, 07:02:59 AM by shan77 »

Offline Tim B.

  • CESMUser
  • Newbie
  • *
  • Posts: 17
Re: Deployment Error. Unknown Error
« Reply #7 on: January 16, 2012, 06:39:41 AM »
w-e-v, thank you for such detailed report.

As I can see the remote admin share is inaccessible. This is because of privilegies lack for ESM server. If login and password you entered are correct, then I'd recommend you to check the following registriy values on target mchines.

1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\forceguest DWORD registry value should be set to 0
2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\LocalAccountTokenFilterPolicy DWORD registry value should be set to 1

I have prepared a small REG file that may help you with registry values modifications (attached to this post in ZIP archive). Just double-click extracted file on the issued targets and the values will be added/updated in registry. Anyway please check that values are correct.

After registry modification please try again deployment or admin$ share access test.

[attachment deleted by admin]

Offline shan77

  • Newbie
  • *
  • Posts: 18
Re: Deployment Error. Unknown Error
« Reply #8 on: January 16, 2012, 07:03:52 AM »
Thanks for the reg file, it's very useful for us, too!

Offline Tim B.

  • CESMUser
  • Newbie
  • *
  • Posts: 17
Re: Deployment Error. Unknown Error
« Reply #9 on: January 16, 2012, 07:26:49 AM »
Hope it will help!

Offline alex_gubernsky

  • CESMUser
  • Newbie
  • *
  • Posts: 12
Re: Deployment Error. Unknown Error
« Reply #10 on: January 16, 2012, 08:12:19 AM »
Quote
•Description: production purpose
•License type: Normal
•Lic. status: Valid
•Products: livePCsupport

Hi Shan,

As you can see from the license information the license you purchased contains only "livePCsupport" product (also the name of your license "Comodo Endpoint Security Manager V2.0 Business Edition Console" says that this is a "Console Only" license). Therefore it doesn't allow to deploy CIS on your endpoints. But that doesn't mean you can't have CIS installed manually and then connected to ESM. So there are two possible options:

  • Upgrade your license to the one, which contains CIS and deploy it through ESM.
  • Install CIS manually and connect it to ESM using "Manage This Endpoint" option in CIS UI.

Offline shan77

  • Newbie
  • *
  • Posts: 18
Re: Deployment Error. Unknown Error
« Reply #11 on: January 16, 2012, 08:32:53 AM »
Hi Shan,

As you can see from the license information the license you purchased contains only "livePCsupport" product (also the name of your license "Comodo Endpoint Security Manager V2.0 Business Edition Console" says that this is a "Console Only" license). Therefore it doesn't allow to deploy CIS on your endpoints. But that doesn't mean you can't have CIS installed manually and then connected to ESM.

Hi Alex!

Finally someone gave me a sensible answer! Thank you!
I tried to get answer on livesupport, but noone gave me that information.
May I ask you, which license should I buy? And how much will it cost for 100 pc?

Greetings,
shan

Offline w-e-v

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 1503
  • BETA FORCE MEMBER
Re: Deployment Error. Unknown Error
« Reply #12 on: January 16, 2012, 09:06:31 AM »
Hi Alex!

Finally someone gave me a sensible answer! Thank you!
I tried to get answer on livesupport, but noone gave me that information.
May I ask you, which license should I buy? And how much will it cost for 100 pc?

Greetings,
shan


Hello Shan:

With the license you have, you can still manage 100 endpoints from 1 console, but you will have to install CIS and the agent MANUALLY in every computer (yes, one hundred installations).

If you dont want to do that, and you want to install CIS and the agent AUTOMATICALLY from the console, then you need to purchase:
Comodo Endpoint Security Manager V2.0 Business Edition-100 seat  (100 - 100 endpoints)

In the same link you used to purchase your current license, you will find that the 4th option of the list is the solution you are looking for. The price is $99 for 1 year.


Regards,

Offline w-e-v

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 1503
  • BETA FORCE MEMBER
Re: Deployment Error. Unknown Error
« Reply #13 on: January 16, 2012, 09:10:56 AM »
Hello Tim, and thank you so much for your personal interest and assistance.


If login and password you entered are correct...

In all cases, I never entered login and password.
I literally typed this in the command prompt from ESM SERVER:
\\192.168.10.106\admin$
\\192.168.10.107\admin$
\\192.168.10.116\admin$

Did I misunderstood? Should I type something else, instead of "admin$" (maybe the real Administrator username of each PC) in order to receive a prompt to enter the password?


As I can see the remote admin share is inaccessible. This is because of privilegies lack for ESM server. If login and password you entered are correct, then I'd recommend you to check the following registriy values on target mchines.

1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\forceguest DWORD registry value should be set to 0
2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system\LocalAccountTokenFilterPolicy DWORD registry value should be set to 1

This was already changed on every target machine because we read the documentation in the QUICK START GUIDE, where it can be found here:
http://enterprise.comodo.com/security-solutions/endpoint-security/endpoint-security-manager/free-trial_be.php


I really dont think that priviledge is the problem.
If you read again the answers I get in the console, these are:
The network path was not found

The main question remains:
WHY DO I GET A NETWORK ERROR EVEN IF I AM TRYING TO DEPLOY CIS LOCALLY IN THE SAME ESM SERVER?


NOTE: Thank you for the small REG file. Its very helpful and I will use it in other installations.  :-TU

Offline shan77

  • Newbie
  • *
  • Posts: 18
Re: Deployment Error. Unknown Error
« Reply #14 on: January 16, 2012, 09:18:40 AM »
Thanks w-e-v, I've found it, but I don't want to buy for additional 100 $. Unless a refund would be possible for the "console only" ESM. :)

Many thanks for all!

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek