Author Topic: Agents not talking...  (Read 18056 times)

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Agents not talking...
« on: July 26, 2010, 11:18:31 AM »
Since the update agents arent talking back to the CESM. I either have to remote to their machines to restart the service or uninstall reinstall the agent. This morning I have only 1 agent talking to the CESM when I should have about 40 or so connected. What's up?

Offline Ester

  • Comodo Member
  • **
  • Posts: 26
Re: Agents not talking...
« Reply #1 on: July 27, 2010, 09:41:37 AM »
It could be that endpoint OS switches to sleeping mode and closes network connections.

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #2 on: July 27, 2010, 04:29:46 PM »
I wish that were the case. All machines were active. I had to restart the CESM to get it working. This is becoming a every day thing now.

Offline Dennis R.

  • Newbie
  • *
  • Posts: 5
Re: Agents not talking...
« Reply #3 on: July 28, 2010, 06:00:46 AM »
Hi,

 In order to better help you please provide us with a short description of your systems like,
 1. What is the configuration of the server and client(s) (Windows version, SQL Server version and package type, CESM version) ?
 2. Are the PCs on the network always on, even if they are unattended?

 Please clarify, which component from the CESM have you had to restart in order to get it working again (CESM server, CESM Console or the CESM Agent on the machines)?
 You mentioned that you created a remote connection and restarted the CESM Agent on the machines. Did you perform any other actions on the PC(s) like restart, agent re-installation before performing the remote?
 On one of the endpoints that was not communicating with the CESM server try to disable the power management features and let it run without user interaction a few hours to see if it still gets disconnected from the server.

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #4 on: July 28, 2010, 11:13:13 AM »
CESM 1.6 is running on Win Server 2008 with SQL 2005 Enterprise. I have narrowed it down to the CESM I believe. Before I was manually restarting the service on the workstations, but I have noticed that if I restart the CESM service and login to the CESM all the machines show as online. All of our users have laptops so they are in and out, but there are a select few that are always on. We disable all power options in the AD GPO when the laptops are plugged in. But the times that I am seeing no laptops online is when everyone is in the office working. But when I restart the CESM server serivce they are back.

Offline Dennis R.

  • Newbie
  • *
  • Posts: 5
Re: Agents not talking...
« Reply #5 on: July 29, 2010, 01:14:27 AM »
Hi,

On the clients that appear as offline what operating system do you have installed?
Also, on the Windows 2008 is the power management for the network adapter been disabled?
Did you have any other version of CESM previously installed? If yes, what version and what were the steps you performed in order to upgrade. Has this problem been from the moment you installed CESM 1.6 or just started to appear?

Regards,
Dennis

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #6 on: July 31, 2010, 02:07:25 AM »
I guess you have never used Windows Server before. There are not power option settings... It's a server. You can read my post for version of CESM and how I upgraded. Agents are spread across Win XP, Vista, and 7. It happens every so often now. I didn't notice it when we first upgraded due to issues upgrading which you will see in post from the CESM 1.6 launch post at the top.

Offline Dennis R.

  • Newbie
  • *
  • Posts: 5
Re: Agents not talking...
« Reply #7 on: August 02, 2010, 04:00:54 PM »
Hi,

The power options I was referring to were those on the POWER MANAGEMENT tab of the network adapter's driver properties window. In order to get to those settings you need to right click MY COMPUTER, select MANAGE then go to DEVICE MANAGER\NETWORK ADAPTERS and right click your PC's network card. From the menu select PROPERTIES and then POWER MANAGEMENT tab. There you will find the 'ALLOW THE COMPUTER TO TURN OFF THIS DEVICE TO SAVE POWER' checked. IF that is the case just un-check it, press OK and restart the server. The same can be applied on all other PCs.

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #8 on: August 02, 2010, 04:11:32 PM »
That is not the problem. The problem appears when you leave the CESM console active for long periods of time it seems to lose sight of agents. Restarting the CESM service fixes the problem.

Offline Dennis R.

  • Newbie
  • *
  • Posts: 5
Re: Agents not talking...
« Reply #9 on: August 02, 2010, 04:24:34 PM »
You mention that you restart the CESM service. Is the CESM server you are referring to or the CESM Console?

Regards,
Dennis

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #10 on: August 02, 2010, 10:03:11 PM »
Sorry for being ugly here, but I feel like I am constantly repeating myself. CESM Console is not a service. CESM Server would be the service. That is what I am restarting to bring life back to CESM...

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13543
  • Retired - Volunteer Moderator
Re: Agents not talking...
« Reply #11 on: August 03, 2010, 04:00:13 AM »
Hi etaftm,

Can you please post a screenshot of what you are restarting where, maybe that helps to clear the confusion...
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline ratz

  • Comodo Loves me
  • ****
  • Posts: 107
Re: Agents not talking...
« Reply #12 on: August 03, 2010, 04:29:36 AM »
Hi, etaftm.

Of course, Console is not service :).

So, let me summaries:
1) For some reason if you leave console connected to server during some period of time (I suppose endpoint system idle for about 3-4 hr).
2) If you restart CESM Service computers became green.

So my question is:
if you simply reconnect with CESM console to server - disconnect connect?
May be it can help return computers to green state?

Offline etaftm

  • CESMUser
  • Comodo Loves me
  • *
  • Posts: 107
Re: Agents not talking...
« Reply #13 on: August 03, 2010, 12:27:08 PM »
Hi etaftm,

Can you please post a screenshot of what you are restarting where, maybe that helps to clear the confusion...

I figured Comodo would know what a service is and seeing how there is only one service the CESM uses which is CESM Server. It was said several times in this thread. I might have come off as a bit irritated because I am. Saying the same thing over and over can get anyone a bit frustrated.

Hi, etaftm.

Of course, Console is not service :).

So, let me summaries:
1) For some reason if you leave console connected to server during some period of time (I suppose endpoint system idle for about 3-4 hr).
2) If you restart CESM Service computers became green.

So my question is:
if you simply reconnect with CESM console to server - disconnect connect?
May be it can help return computers to green state?


If I close CESM console and re-open it still shows agents as offline.

Thanks Ratz

Offline georgianas

  • CESMUser
  • Comodo Family Member
  • *
  • Posts: 68
Re: Agents not talking...
« Reply #14 on: August 03, 2010, 10:09:00 PM »
Hi etaftm,

You can try to add a dependency on the agent service with DHCP being the dependency and check what happens.You can try it out on a xp endpoint which you know is going offline (it's not green anymore).
You can create a reg file with:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CrmAgnSvc]
"DependOnService"=hex(7):44,00,48,00,43,00,50,00,00,00,00,00

and apply it or just create it manually on the endpoint, by browsing to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CrmAgnSvc , Edit->New->Multi-String Value->name it "DependOnService" and enter for the Value Data "DHCP".

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek