Author Topic: "Unable to Sign" after update of email certificate on iPhone  (Read 2197 times)

Offline kjgriffin

  • Newbie
  • *
  • Posts: 1
First, thanks to Comodo for providing these personal email certificates. 

My prior certificates just expired and I just downloaded a new one.  I managed to install it on my mac without incident, and it's working there.  When I tried to repeat the export the entire certificate path as a .p12 file and put it on my iPhone, it gave the illusion of working:  Under general>profile I see the right email account and new certificate data. 

Unfortunately, when I go back to the mail app, I get an error:  "Unable to Sign.  You can't send signed messages because a signing identity for the address "xxx[at]foo.bar" could not be found.  Go to the Advanced settings for this account to choose a signing identity."  Under said advanced settings, I see the same, new certificate info.  Worse, I've tried turning off S/MIME and/or signing, but every time I go back to a new email, I get the same error, and those settings are turned back on.  Quite the annoying undocumented feature.

I haven't found much relevant to this problem on these fora or knowlegebase.  The googles led to some instances that suggested too-similar replacements and/or Comodo certificates might require delete, then hard reboot phone, then import new certificate.  Unfortunately this didn't change the behavior. 

I'd appreciate any insights/suggestions you all can add.  Thanks,

--KJGriffin


 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek