Author Topic: TrustConnect Keeps Disconnecting for No Reason  (Read 10880 times)

Offline livefreedietravelling

  • Newbie
  • *
  • Posts: 2
TrustConnect Keeps Disconnecting for No Reason
« on: March 25, 2013, 05:26:12 PM »
Hello,

I've just signed up to TrustConnect and everything seems to be working ok, but for some reason after around 40 minutes it disconnects and doesn't reconnect (I don't even think there is an option for this?).

But either way it's very annoying.

Could somebody please let me know how to fix it or what is going on?

I’m using on Windows 7 Home Premium, 64-bit with Intel Atom CPU D525 [at] 1.80 GHZ, 4GB RAM.

here is the log from TC when it connects:

Mon Mar 25 23:27:50 2013 OpenVPN 2.1.1 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Dec 11 2009
Mon Mar 25 23:27:50 2013 WARNING: Make sure you understand the semantics of --tls-remote before using it (see the man page).
Mon Mar 25 23:27:50 2013 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Mon Mar 25 23:27:51 2013 LZO compression initialized
Mon Mar 25 23:27:51 2013 Attempting to establish TCP connection with 91.212.12.67:443
Mon Mar 25 23:27:51 2013 TCP connection established with 91.212.12.67:443
Mon Mar 25 23:27:51 2013 TCPv4_CLIENT link local: [undef]
Mon Mar 25 23:27:51 2013 TCPv4_CLIENT link remote: 91.212.12.67:443
Mon Mar 25 23:27:51 2013 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Mon Mar 25 23:27:56 2013 [ComodoVPNS-3] Peer Connection Initiated with 91.212.12.67:443
Mon Mar 25 23:27:58 2013 TAP-WIN32 device [Local Area Connection 2] opened: \\.\Global\{4590CA09-D4E5-4EF5-A397-083F32377E90}.tap
Mon Mar 25 23:27:58 2013 Notified TAP-Win32 driver to set a DHCP IP/netmask of 172.20.3.49/255.255.255.0 on interface {4590CA09-D4E5-4EF5-A397-083F32377E90} [DHCP-serv: 172.20.3.0, lease-time: 31536000]
Mon Mar 25 23:27:58 2013 Successful ARP Flush on interface [46] {4590CA09-D4E5-4EF5-A397-083F32377E90}
Mon Mar 25 23:28:03 2013 Initialization Sequence Completed


And here is the log for TC when it disconnects:

Tue Mar 26 00:10:40 2013 write TCPv4_CLIENT: Software caused connection abort (WSAECONNABORTED) (code=10053)
Tue Mar 26 00:10:40 2013 Connection reset, restarting [-1]
Tue Mar 26 00:10:40 2013 Warning: route gateway is not reachable on any active network adapters: 192.168.2.1
Tue Mar 26 00:10:40 2013 openvpn_execve: CreateProcess 'env'\system32\route.exe failed: The system cannot find the path specified.   (errno=3)
Tue Mar 26 00:10:40 2013 ERROR: Windows route delete command failed [adaptive]: external program did not execute -- returned error code -1
Tue Mar 26 00:10:40 2013 SIGTERM[soft,connection-reset] received, process exiting

My current config is the default one and has not been modified:

client
dev tap
proto tcp

#emote us1.vpn.comodo.com 443
#emote us2.vpn.comodo.com 443
#emote uk1.vpn.comodo.com 443
remote-random

auth-user-pass
resolv-retry infinite
nobind
persist-key
persist-tun
pull
remap-usr1 SIGTERM

ca ca.crt
ns-cert-type server
tls-remote ComodoVPNS

mute-replay-warnings
mute 2
comp-lzo
verb 1

I would greatly appreciate any help on this.

Regards,
Paul
Full time traveller... loving it!

Offline dlimonov

  • Comodo Loves me
  • ****
  • Posts: 142
Re: TrustConnect Keeps Disconnecting for No Reason
« Reply #1 on: March 26, 2013, 06:03:03 AM »
Hello,

It looks like a Windows error or, probably, something interferes with TrustConnect. Do you have any other software that could use TAP adapter (e.g., another VPN client)?

Offline livefreedietravelling

  • Newbie
  • *
  • Posts: 2
Re: TrustConnect Keeps Disconnecting for No Reason
« Reply #2 on: March 26, 2013, 11:50:00 AM »
Hello,

thanks for the quick reply. Literally nothing else that could be interfering that I'm aware of, how would I be able to check to make sure?

Are you guys able to remote log-in to check any issues?

Thanks,
Paul :-)
Full time traveller... loving it!

Offline dlimonov

  • Comodo Loves me
  • ****
  • Posts: 142
Re: TrustConnect Keeps Disconnecting for No Reason
« Reply #3 on: March 27, 2013, 08:14:26 AM »
Try to connect to another server: right-click on TrustConnect icon -> "Advanced options" -> "I want to connect to server in:" (or "Let me choose each time I connect") and try each of three servers. Does the issue persist?
And certainly, contact the support.

Offline jdaviet

  • Newbie
  • *
  • Posts: 1
Re: TrustConnect Keeps Disconnecting for No Reason
« Reply #4 on: April 07, 2013, 05:28:14 AM »
Same problem here, but after 1 minute:

Sun Apr 07 11:14:13 2013 LZO compression initialized
Sun Apr 07 11:14:13 2013 Attempting to establish TCP connection with -----deleted--
Sun Apr 07 11:14:13 2013 TCP connection established with ---------deleted--
Sun Apr 07 11:14:13 2013 TCPv4_CLIENT link local: [undef]
Sun Apr 07 11:14:13 2013 TCPv4_CLIENT link remote: -----------------deleted--
Sun Apr 07 11:14:14 2013 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sun Apr 07 11:14:19 2013 [ComodoVPNS-2] Peer Connection Initiated with ------
Sun Apr 07 11:14:22 2013 TAP-WIN32 device [LAN-verbinding 3] opened: \\.\Global\{7D6A6050-CEAB-4C24-9FDA-F17890C7124E}.tap
Sun Apr 07 11:14:22 2013 Notified TAP-Win32 driver to set a DHCP IP/netmask of ------deleted-- on interface {7D6A6050-CEAB-4C24-9FDA-F17890C7124E} [DHCP-serv: 172.20.1.0, lease-time: 31536000]
Sun Apr 07 11:14:22 2013 Successful ARP Flush on interface [23] {7D6A6050-CEAB-4C24-9FDA-F17890C7124E}
Sun Apr 07 11:14:27 2013 Initialization Sequence Completed
Sun Apr 07 11:14:51 2013 write TCPv4_CLIENT: Software caused connection abort (WSAECONNABORTED) (code=10053)
Sun Apr 07 11:14:51 2013 Connection reset, restarting [-1]
Sun Apr 07 11:14:51 2013 SIGTERM[soft,connection-reset] received, process exiting

Offline dlimonov

  • Comodo Loves me
  • ****
  • Posts: 142
Re: TrustConnect Keeps Disconnecting for No Reason
« Reply #5 on: April 08, 2013, 03:08:43 AM »
Did you try to choose another access server?

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek