Author Topic: Linix Mint 18 - another error message?  (Read 4108 times)

Offline ChrisJT

  • Newbie
  • *
  • Posts: 1
Linix Mint 18 - another error message?
« on: August 22, 2016, 07:03:48 AM »
I can't see a topic for this.  I have freshly installed Mint 18 on my 64-bit machine and, when downloading and trying to install Comodo AV I get the message that a dependency is not satisfied - libssl0.9.8.  Linux Mint 18 has libssl1.0.0 installed - the old 0.9.8 is not available in the software manager!  Do we need Comodo AV to be updated to recognize libssl1.0.0 as this apparently has now replaced the older version?

Offline silvatech

  • Newbie
  • *
  • Posts: 6
Re: Linix Mint 18 - another error message?
« Reply #1 on: September 06, 2016, 06:04:17 PM »
You can have libssl0.98 installed along side libssl1.0.0 I found out.

Wierd I actually wrote a tutorial on this and apparently it even got deleted or it never posted right.

Here are my notes on it with where to download libssl0.9.8 Any questions please let me know.

How to install comodo Anti Virus on 16.04


This guide will show you how to install Comodo anti virus on Ubuntu 16.04. While I agree normally you don't need a virus scanner on linux. Their are situations that you are required to have one.

I will try to update this guide later with some pictures if people get confused, but I think it is pretty straight forward. Any questions feel free to contact me.

You will need to install Libssl0.9.8 as the SSL on 16.04 is newer and does not replace the older one, both can be installed. That live can be found here.

http://packages.ubuntu.com/precise/amd64/libssl0.9.8/download

Comodo can be downloaded for free from the site provided below.

https://www.comodo.com/home/download/download.php?prod=antivirus-for-linux

once you have the file you can goto the directory in terminal to install it.

sudo dpkg -i cav-linux_x64.deb

Once its installed you will have a filter driver issue error. Which can be fixed by replacing a file.

http://www.bondoffamily-net.com/~kinta-chan/techknow/DownLoad/DownLoad.html

Download

Download driver.tar(redirfs 0.11E12A)
Download fix_rebuild_driver.sh

Replace driver.tar to /opt/COMODO
copy fix_rebuild_driver.sh to /opt/COMODO

for next step you will need to be in the /opt/COMODO director

cd /opt/COMODO

sudo chmod +x /opt/COMODO/fix_rebuild_driver.sh

sudo ./fix_rebuild_driver.sh
sudo ./post_setup.sh
go through the prompts.

restart the computer.

You should have a new error Mail gate way is not running

click for it to scan the system which will make Comodo update itself. Once its uptodate reboot and all the errors shoudl be gone. If not click on the error and it will  ask you if you like it to try to fix itself answer yes and reboot and you should be good to go.
« Last Edit: September 06, 2016, 06:06:30 PM by silvatech »

Offline Mirmos

  • Newbie
  • *
  • Posts: 15
    • Oserblog
Re: Linix Mint 18 - another error message?
« Reply #2 on: October 15, 2016, 09:02:30 AM »
Hi silvatech
I've been successfully running the full CAV for the last 3 years up to and including Ubuntu16.04 with kernel 4.4.0-43 by using the Kinta-Japan unofficial driver.tar file, replacing it with itself each time there was a kernel update and running post_setup.sh
Unfortunately this has now failed for Ubuntu 16.10 with its kernal4.8.0-x . I've not needed to run fix_rebuild_driver.sh up to now, but just tried it as well, as per your suggestion and instructions, to see if it helped.  Unfortunately it hasn't.
As far as I can see there has been no update of the unofficial driver at  http://www.bondoffamily-net.com/~kinta-chan/techknow/DownLoad/DownLoad.html  for a long time.
So i guess it is now really the end of the road for Comodo Antivirus for Linux?
If it is still available (haven't checked recently, but I used to use it) ESET's antivirus for Linux (paid-for) seems a decent user-friendly product with real time protection. Unless you have any other ideas...?

Offline silvatech

  • Newbie
  • *
  • Posts: 6
Re: Linix Mint 18 - another error message?
« Reply #3 on: October 15, 2016, 01:24:30 PM »
thanks for the update, I have not tried 16.10 yet , so I would not know. Yeah, sadly Comodo does not seem to be supporting this project for newer Linux OS. 

Offline Dennis2

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 9226
Re: Linix Mint 18 - another error message?
« Reply #4 on: October 15, 2016, 05:19:03 PM »
Whilst the board is still here there is some hope it will eventually be updated :)

Dennis
Moderator: Aims Forum a friendly place. Any concerns? Please PM me and/or review the Forum Policy 2012Updated.
System: Fedora 25 x64, APF, HTTPS Everywhere, ABP
Centos-6.8 x32, APF, HTTPS Everywhere, ABP

Offline silvatech

  • Newbie
  • *
  • Posts: 6
Re: Linix Mint 18 - another error message?
« Reply #5 on: October 15, 2016, 05:52:16 PM »
Whilst the board is still here there is some hope it will eventually be updated :)

Dennis

Good point Dennis and I plan to keep an eye now and then on this forum for any news.

Offline nmnick89

  • Newbie
  • *
  • Posts: 3
Re: Linix Mint 18 - another error message?
« Reply #6 on: January 04, 2017, 04:28:21 PM »
I had worked around this issue by installing the 32-bit version of Comodo on my 64-bit version of Linux Mint 18.1 and it seems to work fine. Is there any disadvantage to having it installed like this or should I reinstall the 64-bit version of Comodo and run the fixes that Silvatech put on here?

Offline silvatech

  • Newbie
  • *
  • Posts: 6
Re: Linix Mint 18 - another error message?
« Reply #7 on: January 05, 2017, 07:23:32 PM »
I had worked around this issue by installing the 32-bit version of Comodo on my 64-bit version of Linux Mint 18.1 and it seems to work fine. Is there any disadvantage to having it installed like this or should I reinstall the 64-bit version of Comodo and run the fixes that Silvatech put on here?

Theoretically it should not effect it in any bad way. Interesting the 32bit version is working and not the 64bit. I will have to test this out my self to see if I get similar results. Thanks for letting me know =).

Offline goodolandy

  • Newbie
  • *
  • Posts: 18
Re: Linix Mint 18 - another error message?
« Reply #8 on: January 06, 2017, 02:21:37 PM »
I had worked around this issue by installing the 32-bit version of Comodo on my 64-bit version of Linux Mint 18.1 and it seems to work fine. Is there any disadvantage to having it installed like this or should I reinstall the 64-bit version of Comodo and run the fixes that Silvatech put on here?

You peaked my curiosity that I just had to see for myself and you are correct.  The 32 bit doesn't complain about dependency issues, unlike the 64 bit which does.  The 32 bit does, however, complain about "Filesystem filter driver is not loaded!" but other than that, appears to work fine.

Hopefully, the new version that Melih mentioned in another thread will be out soon in a fully working 64-bit edition.

Offline silvatech

  • Newbie
  • *
  • Posts: 6
Re: Linix Mint 18 - another error message?
« Reply #9 on: January 06, 2017, 08:33:20 PM »
You peaked my curiosity that I just had to see for myself and you are correct.  The 32 bit doesn't complain about dependency issues, unlike the 64 bit which does.  The 32 bit does, however, complain about "Filesystem filter driver is not loaded!" but other than that, appears to work fine.

Hopefully, the new version that Melih mentioned in another thread will be out soon in a fully working 64-bit edition.

interesting, I will report back what happens with my current installation in XFCE as well and report back. Thanks goodolandy for your results on this. =)

Offline nmnick89

  • Newbie
  • *
  • Posts: 3
Re: Linix Mint 18 - another error message?
« Reply #10 on: January 12, 2017, 03:49:25 AM »
you can fix the "filesystem......." error with the instructions found here https://ubuntuforums.org/archive/index.php/t-2144917.html.  This worked for me. The only drawback is that you have to repeat this process every time you update the kernel. I heard somewhere too that it doesn't work beyond kernel version 4.7. Not sure how true that is because I am running kernel version 4.4.x. I will test this out in one of my virtual machines that is running kernel version 4.8.x. Hope this is all helpful.
« Last Edit: January 12, 2017, 01:09:42 PM by nmnick89 »

Offline nmnick89

  • Newbie
  • *
  • Posts: 3
Re: Linix Mint 18 - another error message?
« Reply #11 on: January 14, 2017, 10:29:04 PM »
I tested the 32-bit version of Comodo on my virtual machine which is running Fedora 25 and Kernel version 4.8.x. The install went smoothly, however when I ran the post install script I got errors stating that the Kernel headers for the software were not up to date. These errors were different from when I installed it on Linux mint 18.1 with Kernel version 4.4.x (which is what my computer runs natively). Since the "driver.tar" file mentioned in the link above is not meant to address this issue, I did not download and test it. The moral of this story is that we badly need a version update of Comodo that addresses all of the issues with both the 32-bit and 64-bit versions. For now though, as long as you are running Kernel 4.7.x or below, Comodo should work.

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek