Author Topic: Can't Install last Comodo AntiVirus for Linux 64 bit version  (Read 2235 times)

Offline jotape1960

  • Newbie
  • *
  • Posts: 2
Hi!!!

I'm using Ubuntu Studio 16.04, 64 bit OS, and I couldn't install the last version of Comodo AntiVirus for Linux (64 bit version).

The system (GDebi installer) told me:

"Error: No se puede satisfacer la dependencia: libssl0.9.8 (>=0.9.8m-1)"

(Error: Can't satisfy 'libssl0.9.8' dependency (>=0.9.8m-1))

However, the 32 bit version can be installed, but I'm not sure if it would be a good idea to install a 32 bit antivirus software into a 64 bit OS.

How could I fix this? ???

Thanks a lot for your time!!!

Greetings & Blessings from Chile!!!!!!!

Juan

Offline blotosmetek

  • Newbie
  • *
  • Posts: 3
Re: Can't Install last Comodo AntiVirus for Linux 64 bit version
« Reply #1 on: May 20, 2016, 02:28:55 PM »
I managed to install CAVL on Ubuntu 16.04, the trick is to install libssl0.9.8 from the 14.04 package: http://packages.ubuntu.com/trusty/libssl0.9.8

However, this only allows me to scan on demand. The very important functionality of scanning on access requires two kernel modules (redirfs and avflt), which do not compile on 16.04. I have tried to use KINTA-JAPAN's patch (see https://forums.comodo.com/comodo-antivirus-for-linux-cavl/filesystem-filter-driver-for-kernel-35314redirfs-and-avflt-t94441.0.html for details), but to no avail - the patch compiles, but hangs the system; apparently it is not compatible with 4.4 kernel (which comes as default with Ubuntu 16.04).

Offline timgelvin

  • Newbie
  • *
  • Posts: 1
Re: Can't Install last Comodo AntiVirus for Linux 64 bit version
« Reply #2 on: June 06, 2016, 10:43:28 AM »
The better trick is for Comodo to update the programming to use libssl 1.0 or better.

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek