Author Topic: Since installing CPF, problems reconnecting to internet  (Read 5302 times)

Offline LM7

  • Comodo Member
  • **
  • Posts: 44
Since installing CPF, problems reconnecting to internet
« on: August 23, 2006, 02:38:48 AM »
When I turn off my internet connection temporarily, whether by right-clicking the DSL icon and clicking "Disconnect", physically unplugging my (DSL) modem, or even clicking "BLock All" on CPF, and then I try to reconnect to the internet, I am unable to do so, unless I completely rebooting the computer.

Sometimes when I try to reconnect I get an error message reading "TCP/IP CP reported error 31: a device attached to the system is not functioning"; other times (usually after I try reconnecting) I don't get such a message, but when I check the internet connection icon I notice that there's no activity there, and I get a message "Firefox Can't FInd the Server at [Specified URL].

I never had such problems using other firewalls; any ideas?

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3380
Re: Since installing CPF, problems reconnecting to internet
« Reply #1 on: August 23, 2006, 04:57:53 AM »
When I turn off my internet connection temporarily, whether by right-clicking the DSL icon and clicking "Disconnect", physically unplugging my (DSL) modem, or even clicking "BLock All" on CPF, and then I try to reconnect to the internet, I am unable to do so, unless I completely rebooting the computer.

Sometimes when I try to reconnect I get an error message reading "TCP/IP CP reported error 31: a device attached to the system is not functioning"; other times (usually after I try reconnecting) I don't get such a message, but when I check the internet connection icon I notice that there's no activity there, and I get a message "Firefox Can't FInd the Server at [Specified URL].

I never had such problems using other firewalls; any ideas?

Do you have any other firewalls installed but disabled?

Offline LM7

  • Comodo Member
  • **
  • Posts: 44
Re: Since installing CPF, problems reconnecting to internet
« Reply #2 on: August 23, 2006, 05:41:29 AM »
No, I did a complete uninstall on my previous FW (Jetico) and rebooted before installing CPF.

Offline Herschel

  • Newbie
  • *
  • Posts: 16
Re: Since installing CPF, problems reconnecting to internet
« Reply #3 on: August 24, 2006, 12:27:43 AM »
I also have had to log off and on, or reboot, to restore internet connect after blocking something.

Its as if Comodo thinks iexplorer, once dirty, cannot be cleaned by closing and restarting things.

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3380
Re: Since installing CPF, problems reconnecting to internet
« Reply #4 on: August 24, 2006, 12:38:18 AM »
I also have had to log off and on, or reboot, to restore internet connect after blocking something.

Its as if Comodo thinks iexplorer, once dirty, cannot be cleaned by closing and restarting things.

It should be asking about a parent application perhabs?

Offline Herschel

  • Newbie
  • *
  • Posts: 16
Re: Since installing CPF, problems reconnecting to internet
« Reply #5 on: August 24, 2006, 03:09:20 PM »
It should be asking about a parent application perhabs?
Closing and restarting IE's parent (Explorer) in Taskman did not restore browser function.

This loss of browser function is not consistent. Yesterday, with the 5 WallBreaker tests,  I just had to close and restart IE to restore browser function everytime. Today, I had no browser function after booting and had to reboot.
« Last Edit: August 31, 2006, 02:01:30 PM by Herschel »

Offline Herschel

  • Newbie
  • *
  • Posts: 16
Re: Since installing CPF, problems reconnecting to internet
« Reply #6 on: August 31, 2006, 02:06:28 PM »
Perhaps CPF is blocking my network connection after detecting "suspicious activity" in either "Application Monitor" or "Network Monitor".  Perhaps my so called "inconsistant behavior" is actually differences in the cause of the blocking onset.

To restore browser function:

(1)  It seems that sometimes when I have waited long enough, the browser works again.
(2)  Sometimes closing and reopening the browser seems to work but not always.
(3)  Sometimes switching CPF to "Allow all", then back to "Custom" seems to work.
(4)  Rebooting (or perhaps just logging off and on?) will normally work (but I had at least one case of the network connection being blocked after boot, and had to boot again).

comicfan2000

  • Guest
Re: Since installing CPF, problems reconnecting to internet
« Reply #7 on: August 31, 2006, 04:02:32 PM »
In a scenario such as this, it would also be good to do the following...

 1. Make sure you have all the updates for your OS. SP1 is required to run Comodo I believe but SP2 will work much better.

 2. Make sure you are ABSOLUTELY free from spyware and viruses before installing a security application.

 3. Make sure you arent' conflicting with other things on your computer. Some have other programs installed that may cause grief for a firewall like Limewire, bit torrent baddies that hide in the registry, things like that or a number of others.

 4. Make sure you didn't block svchost or another needed process that will affect your pc in different ways.

  5. Make sure you ISP isn't using a built in firewall, this will and can be an issue.

  6. Make sure Windows XP firewall is set to off, and go to advanced connections and make sure LAN is "Unchecked" as Windows will monitor this by default even when set to off.

  7. Make sure your hard drive is cleaned up, defragmented, running smoothly as possible.

  8. If you are behind a router, you may have to set your Nat\ etc... configuration.

  9. Check other security apps , disable at startup and see if one may be conflicting with Comodo.

  10. Uninstall Comodo CPF thoroughly, reinstall and set to autoconfiguration and see how it works, then adjust the settings as needed.

  11. Make sure the comodofirewall.exe installer file is on the same partition as your OS.

 


  Just a few mentions, make sure your browsers are up to date, and some toolbars like Google , Yahoo, etc...have had conflicts with programs as well. Go into IE properties and make sure your browser settings are correct, or reset them to default and see if this helps. Some cases may be a faulty NIC card and will throw your connection and firewall off a bit and work erratically.

 These are some basic things to check , not saying a rule of thumb, but they have worked for others.
   
Cheers,

 Paul

Offline LM7

  • Comodo Member
  • **
  • Posts: 44
Re: Since installing CPF, problems reconnecting to internet
« Reply #8 on: September 15, 2006, 05:59:15 AM »
I recently did an experiment, which revealed the cause of the problem (which persists ever now, with the release version of CPF): I uninstalled Kaspersky Antivirus, and then re-installed CPF, and had no problems; only after I re-installed KAV did I have this problem (even w/o the Proactive Defense of KAV enabled).

Any ideas about how to solve this?

Offline Techie

  • Newbie
  • *
  • Posts: 2
Re: Since installing CPF, problems reconnecting to internet
« Reply #9 on: September 16, 2006, 12:26:33 PM »
Only notice if CPF is not loaded itself, the Internet connection is severed.
It does not load when the tray icon is loaded.
So I  made a shortcut to cpf in the startup folder.
Works fine.
but should not have to load cpf, it should load automatically when Comodo Tray loads.
(Tray) Note it doesn't load automatically when installed.
It did before this latest release update.
Yes I was clean of all spyware - PC was checked with Mcafee, then uninstalled.
First thing that was ever installed on this PC was COMODO
PC came with Mcafee.

 (B)

Offline rki

  • Comodo Family Member
  • ***
  • Posts: 89
  • Rootcontest.com
    • RootContest - Home of Elite Wargames
Re: Since installing CPF, problems reconnecting to internet
« Reply #10 on: September 19, 2006, 05:28:01 PM »
I recently did an experiment, which revealed the cause of the problem (which persists ever now, with the release version of CPF): I uninstalled Kaspersky Antivirus, and then re-installed CPF, and had no problems; only after I re-installed KAV did I have this problem (even w/o the Proactive Defense of KAV enabled).

Any ideas about how to solve this?

Greetings,
  This goes for all those having Issues with Kaspersky Antivirus(KAV) & COMODO Personal Firewall(CPF)

Navigate to the following

1) Right-click Kaspersky AV icon in system tray. In the shortcut menu select Settings.
- Click Protection - Trusted Zone.
- Click Exclusions Masks tab - Add. Make sure the 'Object' option is cheked.
- By the Object name click 'Specify'.
- Browse to the Outpost folder (by default C:\Program Files\Comodo\Firewall) and checkmark the option "Include subfolders".
- By the Checking task click Selected.
The line should look this way:

The object will not be scanned if the following conditions are met:
Object name: C:\Program Files\Comodo\Firewall
Checking task: any task


- Save your settings by clicking OK 3 times.

2) Click Protection - Trusted Zone.
- Click Trusted Application tab - 'Add' & 'Browse' to the C:\Program Files\Comodo\Firewall folder  and select
  cpf.exe & cmdagent.exe
- "Properties:" -and select
  "Do not scan open files" - " Do not control application activity" - "Do not scan network traffic"

- Save your settings by clicking OK 3 times.

3) Right-click CPF icon in system tray(Open). In the shortcut menu select 'Settings'.
- Application - Monitor - +Add
- Application/Parent Application - select "Learn the parent"
- Browse to the KAV folder(C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0) and select 'avp.exe' so, at the end you should have this: C:\Program Files\Kaspersky Lab\Kaspersky Anti-Virus 6.0\avp.exe

  Now the Rules!
General:
Action: Allow
Protocol: TCP or UDP
Direction: In/Out
Destination IP: Any
Destination Port: Any
Miscellaneous: Nothing

Now... that should do it! "Reboot" -and you're done.





Thanks,
rki.


RootContest.com - Home of Elite Wargames.

Offline LM7

  • Comodo Member
  • **
  • Posts: 44
Re: Since installing CPF, problems reconnecting to internet
« Reply #11 on: September 20, 2006, 05:42:57 AM »
I tried this, and unfortunately it didn't work.

I would like to stress: until I manually disconnect from the internet, everything works fine; it's only when I try to reconnect that I can't establish a connection w/o rebooting.

Offline rki

  • Comodo Family Member
  • ***
  • Posts: 89
  • Rootcontest.com
    • RootContest - Home of Elite Wargames
Re: Since installing CPF, problems reconnecting to internet
« Reply #12 on: September 20, 2006, 09:23:21 AM »
I tried this, and unfortunately it didn't work.

I would like to stress: until I manually disconnect from the internet, everything works fine; it's only when I try to reconnect that I can't establish a connection w/o rebooting.

Greetings,
- Are you sure you're running Kaspersky AntiVirus(KAV) -OR- Kaspersky Internet Security(KIS)

- If you're running KIS? then that should explain it, because it does come with a firewall. And 2 Firewalls don't mix together.

- But, assuming you're running KAV? Are you sure you deleted an Rules on the Application Monitor to Kaspersky(avp.exe) first? If not? delete it and when avp.exe is trying to connect to the Internet you should get a pop-up from CPF.

- Then, assuming you're still running KAV and all this didn't work? then please take a screen shot of your Network Rules and let's see what you've got + copy/paste your logs to see what CPF is really blocking(on assumption this has to do with CPF).




Thanks,
rki.


RootContest.com - Home of Elite Wargames.

Offline LM7

  • Comodo Member
  • **
  • Posts: 44
Re: Since installing CPF, problems reconnecting to internet
« Reply #13 on: September 20, 2006, 11:59:40 AM »
1. I'm running KAV, not KIS.

2. I deleted Avp.exe, and I got a popup when it wanted to connect to the Net.

3. With Comodo installed, I was unable to send mail (although I was able to download it) or to post to this forum!.

4. Please see the attached material (screenshot + log).

[attachment deleted by admin]

Offline rki

  • Comodo Family Member
  • ***
  • Posts: 89
  • Rootcontest.com
    • RootContest - Home of Elite Wargames
Re: Since installing CPF, problems reconnecting to internet
« Reply #14 on: September 20, 2006, 12:35:17 PM »
Greetings,

Bad /corupted file. Re-attach screenshot with a .jpg and logs as .txt



Thanks,
rki.


RootContest.com - Home of Elite Wargames.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek