Author Topic: Defense+ Bug??? (GameGuard Problem)  (Read 21418 times)

Offline marinius

  • Comodo Family Member
  • ***
  • Posts: 57
Defense+ Bug??? (GameGuard Problem)
« on: June 07, 2008, 12:46:19 AM »
Version 3.0.25.378

I think I have found a bug in "Defense+ Settings" which incidentally "solved" my problem regarding GameGuard restarting the computer while authenticating. Posts of the same problem is found in razor74's thread: http://forums.comodo.com/bug_reports/latest_update_ruined_functionality_of_some_mmorpg_games-t22022.0.html

I updated GameGuard by following 000000's instructions found on page 7 of razor74's thread but when I started the game that used GameGuard the same thing happened. My computer restarted.

What I did to solve the problem without rebooting was:
1. Set the Network and Proactive Defense to "Training Mode". It also worked in Clean & Safe modes
2. Opened "Defense+ settings" (Defense+ - Advanced - Defense+ Settings)
3. Checked "Deactivate the Defense+ permanently"
4. Pressed "Apply" but when I was prompted to restart the computer I pressed "No"
5. Then I reversed the process by unchecking "Deactivate the Defense+ permanently" without restarting the computer by pressing "No" again.

It solved the problem without restarting the computer. The game (FLYFF) started smoothly without rebooting the computer. I don't know if this will work with other games.

My questions now are:
1. Was Defense+ not affected by what I did?
2. Was Defense+ still activated/functioning eventhough I did not restart the computer?
3. Why did Defense+ allow GameGuard to run after I did the procedure mentioned above

« Last Edit: September 21, 2008, 08:29:27 AM by marinius »

Offline Munemasa Katagiri

  • Comodo's Hero
  • *****
  • Posts: 214
Re: Defense+ Bug???
« Reply #1 on: June 09, 2008, 10:05:27 AM »
I'll try that also to see if it solves my problem. Thanks for the tips.  :Beer
EDIT: It worked here also but, you need to do those steps again when you restarts.
« Last Edit: June 09, 2008, 10:32:32 PM by Munemasa Katagiri »

Offline marinius

  • Comodo Family Member
  • ***
  • Posts: 57
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #2 on: June 10, 2008, 05:39:37 AM »
Hello Munemasa  Katagiri,

Please let me know if it worked for you.

marinius

Offline Munemasa Katagiri

  • Comodo's Hero
  • *****
  • Posts: 214
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #3 on: June 10, 2008, 10:39:01 AM »
It worked, and you don't even need to change their settings, just check the disable Defense+ box, don't restart, and uncheck it again. The game opens and doesn't reboot you. But, when you restart your computer, you need to do it again or Gayguard will reboot you.

Offline razor74

  • Comodo Loves me
  • ****
  • Posts: 151
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #4 on: June 11, 2008, 10:53:15 AM »
This is happened with older versions of Game Guard. Witha Latest revision - 1196, D + work fine.

Offline Munemasa Katagiri

  • Comodo's Hero
  • *****
  • Posts: 214
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #5 on: June 11, 2008, 01:10:30 PM »
It's up to the games' plublishers to update Gameguard, some of them just don't look like doing it.

Offline marinius

  • Comodo Family Member
  • ***
  • Posts: 57
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #6 on: June 24, 2008, 08:13:51 AM »
Yes Munemasa, I forgot to add in my post that you have to do the procedure all over again when you reboot. Anyway, razor74's news that GameGuard's latest revision (1196) had solved the problem will put this "nightmare" to rest...enjoy your games... 

marinius :BNC

Offline Munemasa Katagiri

  • Comodo's Hero
  • *****
  • Posts: 214
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #7 on: June 28, 2008, 06:50:20 PM »
Unfortunately the games'publishers must update their versions.  (:SAD) Some of them are just lazy to do that.  :THNK

Offline marinius

  • Comodo Family Member
  • ***
  • Posts: 57
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #8 on: July 05, 2008, 07:58:55 PM »
Yes, that's the problem with some of them...

Offline BBeat

  • Comodo Loves me
  • ****
  • Posts: 119
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #9 on: July 24, 2008, 05:11:16 AM »
>Defense+
Registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"AppInit_DLLs"="%windir%\system32\guard32.dll"

>Deactivate the Defense+
Registry key
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"AppInit_DLLs"=""

>What's AppInit_DLLs
ttp://support.microsoft.com/kb/197571
Win10x64, CFW 10.0.1.6294
        ~BFE Bug never fix :D~
CIS have firewall allow/block mixing rule bug started in CIS 5.12, new connection maybe identified as aother app initiate, trust me ;)

Offline Goose19

  • Comodo's Hero
  • *****
  • Posts: 1218
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #10 on: August 07, 2008, 02:19:03 PM »
So has GameGuard updated and fixed the computer restart issue for good?
System Specs:  Pentium 4 with HT 3.06 Ghz,  1.5GB RAM, 160 GB WDC HD, Nvidia Geforce 7600GT 256MB DDR3



New Build: AMD Athlon 64 x2 6000 3.1 Ghz  4 Gb RAM 320GB WDC Hard Drive 650 watt quad rail Power supply(overkill :D) 9500GT Hybrid SLi with 8200 (onboard video) Decent Gaming rig :)

Offline marinius

  • Comodo Family Member
  • ***
  • Posts: 57
Re: Defense+ Bug??? (GameGuard Problem)
« Reply #11 on: August 27, 2008, 07:39:03 PM »
I don't have any personal knowledge with Gameguard lately because I  have already deleted the game which uses it. But according to razor74 above, its already been resolved with revision - 1196.

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek