Author Topic: Click to play (--enable-click-to-play) not working  (Read 3387 times)

Offline Shri624

  • Newbie
  • *
  • Posts: 3
Click to play (--enable-click-to-play) not working
« on: July 31, 2011, 09:35:42 AM »
There's a flag in the chromium based browsers to enable a build-in plugin blocker in the preferences dragon://settings/content
To enable this option, you can add --enable-click-to-play to the command-line options, or enable it in the about:flags options.
It's been around for a while http://downloadsquad.switched.com/2010/08/13/google-chrome-to-get-advanced-plug-in-blocking-think-flashblock/

If you encounter a flash element on a page in Chome/Chromium/Iron and the "Click to play" option is selected, than you'd just have to click the grey placeholder and the flash element /plugin is loaded.

In Dragon: the placeholder is white, which is hard to distinguish from the usual website background.
Also, you have to right click and than enable the plugin. (which is the same behavior as selecting the Block all option in the preferences)

I've tried with the standard flash plugin downloaded from adobe.com and by copying the gcswf32.dll + flashplayercplapp.cpl from the chrome install folder, but it still doesn't work as the other chromium based browsers.

Additional Info
  • Version: 12.2 stable
  • Plugins/Themes: default theme, Flash 10.3
  • Windows 7 PS1 64-bit
  • UAC: Enabled, highest level
  • System Drive: C-drive
  • Install path: C:\Program Files (x86)\Internet Tools\Comodo Dragon
  • User priveleges: tested as admin and limited user

[attachment deleted by admin]

Offline masoudim

  • Newbie
  • *
  • Posts: 3
Re: Click to play (--enable-click-to-play) not working
« Reply #1 on: September 06, 2011, 01:50:30 PM »
+1

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek