Author Topic: "Unable to modify TDB passwd ! Error: Record exists" when creating new web  (Read 10958 times)

Offline rgreene501

  • Comodo Loves me
  • ****
  • Posts: 180
  • Life is too short to drink cheap beer
Setting Up Website   

In Domain matexas.com

--------------------------------------------------------------------------------
Creating home directory ..
.. done
Creating Unix group matexas ..
.. done

Creating Unix user mtexas ..
.. done

Adding new DNS zone ..
.. done

Adding to email domains list ..
.. done

Adding new virtual website ..
.. done

Creating MySQL login ..
.. done

Creating PostgreSQL login ..
.. done

Creating ZTL user ..
.. done

Creating Windows client mtexas ..
Content-type: text/html; Charset=iso-8859-1  Error   



--------------------------------------------------------------------------------

/usr/bin/pdbedit failed :
Unable to modify TDB passwd ! Error: Record exists
 occured while storing the RID index (RID_000007da)

/usr/bin/pdbedit -L shows the appropriate entry
Deleted linux user; ZTL would not create new web; complained about MySQL
deleted MySQL user; ZTL would not create new web; complained about Postgres (hey, I see a pattern here)
deleted Postgres user; ZTL would not create new web; complained about ZTL user
deleted SAMBA user "smbpasswd -x mtexas"

I could not find a way to delete a ZTL user.  "/usr/bin/pdbedit -L" does not list the user mtexas because it was removed with smbpasswd.

Obviously I'm missing something, but I don't know what it is.  I could probably just create the web with a different user, but I could see that leading to problems with orphaned users left lying about.

The user mtexas did not exist prior to the attempt to create this web.

Is there a way to make these additions atomic and roll them back if incomplete?
Pull my finger for my public key

Offline vadim

  • Comodo's Hero
  • *****
  • Posts: 248
/usr/bin/pdbedit failed :
Unable to modify TDB passwd ! Error: Record exists
 occured while storing the RID index (RID_000007da)

Probably, you have changed samba root account manually with 'smbpasswd'

Obviously I'm missing something, but I don't know what it is.  I could probably just create the web with a different user, but I could see that leading to problems with orphaned users left lying about.

 You can try  to create the web with a user mtexas once again.



Offline rgreene501

  • Comodo Loves me
  • ****
  • Posts: 180
  • Life is too short to drink cheap beer
Yes I did.  I did not see the web option a few days ago and I set it so I could join machines to the domain.

It was a test machine, so I just reinstalled.  It didn't do this when I created the web with a fresh install.

Thank you!  (:CLP)
Pull my finger for my public key

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek