Author Topic: Those having installations problems with 8.0 4337  (Read 716 times)

Offline mouse1

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 10112
Those having installations problems with 8.0 4337
« on: November 29, 2014, 07:03:18 AM »
Very sorry you are having these problems.

I have loaded and linked a new version of the CIS Geekbuddy removal tool to Chirons post.
https://forums.comodo.com/install-setup-configuration-help-cis/most-effective-way-to-reinstallupdate-cis-to-avoidfix-problems-t58620.0.html

The file downloads from the same link as the old one.

You may wish to re-try Chiron's reinstallation procedure if you have installation problems which could not be resolved with the old one.

Kind regards

Mike
« Last Edit: November 29, 2014, 07:36:59 AM by mouse1 »

Offline mouse1

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 10112
Re: Those having installations problems with 8.0 4337
« Reply #1 on: December 11, 2014, 07:39:16 AM »
I have experienced the issue mentioned in the subject. Following the detailed guide did not help me at all despite of that there were not any clue of Comodo in the OS (all registry entries[HKLM\SYSTEM\CurrentControlSet, etc.], all files and folders named Comodo were deleted). The error looked persistent but I have figured out that I will start the "C:\ProgramData\Comodo Downloader\cis\download\installs\xml_binaries\cis\cis_setup_x64.msi" installer file.

This way of install misses the regular CIS install look-and-feel and the selectionable setup of additional component. However, an exact error message has been shown during/after the setup.



I have chosen the Ignore and the rest of the install has been finished without any further issue. Finishing the install I have made a little "criminal forensic" seeking for the possible reasons. I launched the depends.exe (Dependency Walker) that revealed me a very interesting detail that hides in the CIS setup process, especially in the "C:\Program Files\COMODO\COMODO Internet Security\cmdstat.dll" file.



As it can be seen, the DLL complains about missing files. The missing files block the normal install process because this error is not handled by the CIS installer, so it just gives back a plain and simple error code and breaks. The msiexec.exe can make differences, so that will offer the choice how to handle the error but it lacks of a bunch of features that belong to the CIS install. Catch of 22... Either way of that way, the install requires now manual human intervention.

The point is, selecting the msiexec.exe method will help to install the CIS 8.0.4337. Later the required features can be added or removed.

P.S.
Despite of the install error there is an additional typo (a glitch) in the registry when the install finishes.



The emphasized word would be (probably) VirtualRoot instead of the VritualRoot...

Thanks for doing all this work.

The "vrtitual root" string is correct.

I am puzzled by the path of the missing files. Are you loading this on device running Windows RT?

As far as I know CIS does not support Windows RT, though CAV Linux may do

One other thought I had is that cmdstat might be the module that give Comodo feedback on usage, so if that option were unticked it might load

Kind regards

Mouse

Offline mouse1

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 10112
Re: Those having installations problems with 8.0 4337
« Reply #2 on: December 14, 2014, 05:59:49 AM »
If you system still will not install CIS 8 after uninstalling previous versions using Chiron's method, including running the Geekbuddy tool, you could try the following if you know what you are doing with the registry editor, and file deletion in system directories and know how to do a system restore in safe mode if needed. Please note these are experimental steps based on my personal experience and are not tried and tested. Please note these steps are carried out at your own risk, and do not carry any guarantee that they will work for you and are not approved by Comodo in any way.

These steps may not help if your problem relates to installation on non-unicode system. But probably worth trying anyway.


0. Make a system restore point
1. Boot to safe mode. (Hold F8 down during the first part of the boot cycle on most computers)
2. Run options 1 and 2 of the Geekbuddy tool again
3. Make sure all the Comodo Internet Security files in the following directories have been deleted
%Windir%/system32
%Windir%/system64
%Windir%/system32/drivers
%Windir%/system64/drivers
Some of these directories will not be present on 32 bit machines. To identify the correct files, sort by company, and check the detail tab in the properties of each Comodo file to see if it is part of Comodo Internet Security.
4. Open Control Panel ~ Admin tools ~ Device manager and switch on view ~ Show hidden devices
5. Find Non-PNP driver Comodo Helper Service and Comodo Firewall Driver right click on them and and uninstall them
6. Go to start ~ Run ~ Regedit
7. Navigate to the following keys and delete or rename them:
https://copy.com/lS2HSqrzWDEH/2014-12-14_09-14-51.png
(On 32 bit machines the path ending 'guard64.dll' will end instead in 'guard32.dll')
8. Shutdown and reboot to normal mode
9. If you system experiences boot problems after performing these instructions try system restore first in normal mode, or if not in safe mode.


« Last Edit: December 14, 2014, 11:42:21 AM by mouse1 »

 

Seo4Smf 2.0 © SmfMod.Com Smf Destek