Author Topic: Very strange: Comodo taking 100% cpu  (Read 39278 times)

Offline euthymos

  • Newbie
  • *
  • Posts: 8
Very strange: Comodo taking 100% cpu
« on: February 28, 2007, 10:15:05 AM »
Dear developers and users,

I've been using Comodo for a week with no problems at all.  (L)

But today I've noticed that, where the number of connection grows up, Comodo starts taking 100% of my processor.
If I start eMule, the whole system completely hangs, but the problem still happens with other programs...

What can I do?  :-[

Thank you in advance.
« Last Edit: February 28, 2007, 10:17:22 AM by euthymos »

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #1 on: February 28, 2007, 10:19:17 AM »
euthymos, what you are experiencing is something I think almost all of us are: the logging.  If you disable it for a moment, will the cpu overload stop?

Offline euthymos

  • Newbie
  • *
  • Posts: 8
Re: Very strange: Comodo taking 100% cpu
« Reply #2 on: February 28, 2007, 10:44:21 AM »
euthymos, what you are experiencing is something I think almost all of us are: the logging.  If you disable it for a moment, will the cpu overload stop?

Which logs do I have to disable, and in which way?


Thank you :)

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #3 on: February 28, 2007, 10:48:13 AM »
 :).  Network Monitor is more than likely to have the most alerts logged because by default all blocked connections are logged by the final block all IP In and Out rule.  To disable that right-click in the Logs window and uncheck it from Log Events From

Offline euthymos

  • Newbie
  • *
  • Posts: 8
Re: Very strange: Comodo taking 100% cpu
« Reply #4 on: February 28, 2007, 10:52:57 AM »
:).  Network Monitor is more than likely to have the most alerts logged because by default all blocked connections are logged by the final block all IP In and Out rule.  To disable that right-click in the Logs window and uncheck it from Log Events From

I've just followed your indications, and they brought instant relief to my processor! :)

CPF is a great firewall, and I think COMODO's develpers should face this problem (maybe they're already doing...).

Thank you!  :)
« Last Edit: February 28, 2007, 10:55:51 AM by euthymos »

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #5 on: February 28, 2007, 11:24:23 AM »
Alternatively, if you want to keep your logs and not encounter this issue, right-click on this file and set it to read-only: C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall\Logs\logs.log.  Unfortunately, your log history will only be kept during CFP's active session.  Once you exit CFP, the log will reset to the point when you set it to read-only. 

There are other ways to limit your traffic logging in the Network Monitor by setting the rules to only alert the ones you want.

Offline Cloud

  • Newbie
  • *
  • Posts: 1
Re: Very strange: Comodo taking 100% cpu
« Reply #6 on: March 11, 2007, 03:42:55 PM »
:).  Network Monitor is more than likely to have the most alerts logged because by default all blocked connections are logged by the final block all IP In and Out rule.  To disable that right-click in the Logs window and uncheck it from Log Events From

Yeah I was getting alot of slowdowns, mostly when I was running Azureus, but now it's working great, thanks for the wonderful program Comodo!

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #7 on: March 11, 2007, 04:46:08 PM »
Welcome to the forum, Cloud.

Hopefully this will be fixed in v3.

Offline SteeL

  • Newbie
  • *
  • Posts: 2
Re: Very strange: Comodo taking 100% cpu
« Reply #8 on: May 13, 2007, 12:08:41 PM »
I solved the Problem.  :Beer

I just did this > Logs > Righ click on all Logs > removed Network Log
Done. :D

Offline bignose

  • Newbie
  • *
  • Posts: 1
Re: Very strange: Comodo taking 100% cpu
« Reply #9 on: May 14, 2007, 07:00:36 AM »
This definitely works.. but even though I disable the logging completely, if i reboot the logging recommences and slowly eats the CPU so the system seizes up.

Until this is fixed in next version, is there any way to permanently shut off the logging for any monitor?  ... or should I just Clear Logs each time I reboot the PC [which is often]

Also, while off topic for this thread is there anyway to stop the Auto updates? It seems that if there is a problem connecting to the Comodo server that the application justs keeps trying and trying which is also creating some small nuisance value.

In spite of these issues, this is a truly fine software firewall, and after a couple more version leaps I'm sure it will be the best..  and it's FREE.. amazing considering i have paid out a fair bit of cash buying and testing and discarding firewalls and A/V programs in the last 9 months..

 (CLY)

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #10 on: May 14, 2007, 08:05:01 AM »
This definitely works.. but even though I disable the logging completely, if i reboot the logging recommences and slowly eats the CPU so the system seizes up.
This is another issue that I also experience.  Please file a ticket http://support.comodo.com

Until this is fixed in next version, is there any way to permanently shut off the logging for any monitor?  ... or should I just Clear Logs each time I reboot the PC [which is often]
Please read my reply above:
Alternatively, if you want to keep your logs and not encounter this issue, right-click on this file and set it to read-only: C:\Documents and Settings\All Users\Application Data\Comodo\Personal Firewall\Logs\logs.log.  Unfortunately, your log history will only be kept during CFP's active session.  Once you exit CFP, the log will reset to the point when you set it to read-only.

Also, while off topic for this thread is there anyway to stop the Auto updates? It seems that if there is a problem connecting to the Comodo server that the application justs keeps trying and trying which is also creating some small nuisance value.
Indeed OT.  But here's the answer anyway: Security > Advance > Miscellaneous > Configure > there are 2 options you can disable.  The error must be 106 or 109.

Most of the info I just posted is in my FAQ signature link.  Please bookmark it for reference.

Offline angelus

  • Newbie
  • *
  • Posts: 3
Re: Very strange: Comodo taking 100% cpu
« Reply #11 on: May 20, 2007, 02:09:05 PM »
Hi, I too was experiencing high CPU usage with cpf and cmdagent. I think I've pretty much resolved them both. This is how I did it :

cmdagent.exe:

1) As others have mentioned, turning off MDI fixes the cpu usage , yes you loose a layer of security but I think I can live with it off until its corrected in a future release. My avg cpu usage for cmdagent is 0%.

cpf.exe:

1) I turned off logging and making logs.log read-only as others have suggested, this didnt help much but I left it off as I don't really care for it keeping a log.

2) Second I turned off SPI In Advanced -> Advanced Attack Prevention and Detection - > Do Protocol Analysis ... I also turned off block fragmented IP datagrams, not really sure if this helps but I figured not much harm can come with having it off, but others may correct me.

3) Lastly and this gave me the biggest results in terms of CPU usage, since the only times I had cpf give me high CPU usage was when I was using apps that require many connections such as P2P , specially with Azureus in my case, I went into Application Monitor, selected the edit option on the Azureus application. You can either check the allow all activities for this application option, or as I did i selected Direction: In/Out under the general tab and everything else was set to Any as they were by default , now under miscellaneous tab , check skip advanced security checks and allow invisible conntection attempts.

After this cpf.exe is peaking at 5% but usually fluctuates between 0 - 3%

It's been like this for over a day using Azureus as normal, hope this helps others too. And here's to hoping the comodo devs come through fixing this great app.
« Last Edit: May 20, 2007, 02:10:36 PM by angelus »

soyabeaner

  • Guest
Re: Very strange: Comodo taking 100% cpu
« Reply #12 on: May 20, 2007, 02:14:30 PM »
2) Second I turned off SPI In Advanced -> Advanced Attack Prevention and Detection - > Do Protocol Analysis ... I also turned off block fragmented IP datagrams, not really sure if this helps but I figured not much harm can come with having it off, but others may correct me.
I recommend against this.  It shouldn't expend cpu because it's at the network traffic level.  Moreover, it definitely is one of the benefits of CFP that other FWs lack.

3) Lastly and this gave me the biggest results in terms of CPU usage, since the only times I had cpf give me high CPU usage was when I was using apps that require many connections such as P2P , specially with Azureus in my case, I went into Application Monitor, selected the edit option on the Azureus application. You can either check the allow all activities for this application option, or as I did i selected Direction: In/Out under the general tab and everything else was set to Any as they were by default , now under miscellaneous tab , check skip advanced security checks and allow invisible conntection attempts.

After this cpf.exe is peaking at 5% but usually fluctuates between 0 - 3%
Thanks for sharing this.  Definitely news to me.  The cpf.exe percentages you're receiving now are already obtainable on my system just by disabling logging.

Offline angelus

  • Newbie
  • *
  • Posts: 3
Re: Very strange: Comodo taking 100% cpu
« Reply #13 on: May 20, 2007, 02:59:35 PM »
I recommend against this.  It shouldn't expend cpu because it's at the network traffic level.  Moreover, it definitely is one of the benefits of CFP that other FWs lack.

Hi, you're right, out of laziness I didn't try it again with both these options turned back on as I've had speed problems with other FW's with SPI enabled. So I just set them both back on and it seems your right, i've been monitoring cpu usage afterwards and so far so good it looks pretty much the same as with them off, cpu and download speeds.  I'll update if this changes but for now step # 2 is off my list of things I did to lower CPU usage for cpf. Thanks.

Offline concerned807

  • Newbie
  • *
  • Posts: 12
Re: Very strange: Comodo taking 100% cpu
« Reply #14 on: June 07, 2007, 04:00:24 AM »
3) Lastly and this gave me the biggest results in terms of CPU usage, since the only times I had cpf give me high CPU usage was when I was using apps that require many connections such as P2P , specially with Azureus in my case, I went into Application Monitor, selected the edit option on the Azureus application. You can either check the allow all activities for this application option, or as I did i selected Direction: In/Out under the general tab and everything else was set to Any as they were by default , now under miscellaneous tab , check skip advanced security checks and allow invisible conntection attempts.
Thanks angelus! This trick gave immediate result once I applied the rule and reloaded my uTorrent.

I wonder however if it is safe to apply the same rule to the Application Rules for eMule...Anyone cares to comment?
OS: Windows XP SP2
Security programs installed:
- Avast Pro 4.7
- Comodo Personal Firewall 2.4.18.184
- System Safety Monitor 2.3.0.612 Full

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek