Author Topic: Failure to Restore System Partition  (Read 4251 times)

Offline ndastar

  • Newbie
  • *
  • Posts: 21
Failure to Restore System Partition
« on: February 13, 2012, 04:38:51 PM »
I am running Win 7 64 professional and  Comodo 4.
I have a 500G HD, partitioned into a 60G C: partition and the rest a D: partition
I have installed the OS and all program files into the C: partition. I am using the D: partition strictly for data.

Backing up and restoring files and directories from / to the D: partition seems to work fine. However, I have been unable to backup and restore the C: partition successfully.

The scenario I want to address is:
* My hard drive fails,
* I buy a new one (not necessarily the same size as the bad one)
* I want to restore the C: partition into the new drive so that I can boot from it and be back in business without having to reinstall the OS and all of my programs.
* I can then, restore my data into a new D: partition from a Data Backup.
* In essence, I want to have two sets of backups: A system backup (C: drive and all information needed to be able to boot from it) and a Data Backup. The reason for the two sets of backups is that I want to make daily incremental backups for my data; however, I only need to make weekly (or at will) incremental backups for the C: drive (since it does not change too often).

Here is what I did:
1. I took a backup using: New Custom Backup --> Disks, Partitions and MBR --> then under Disk 0,  I selected a) Track 0 and MBR, b) (100MB) System Reserve, c) C:\ (59.96GB) C NTFS
2. The options for this backup were the default ones on the screen: incremental, automatic base, CBU file.
3. The backup completed successfully. The backup media was a USB external drive.
4. I then took another backup and CB found the existing base and made an incremental backup.
5. I then shut down the machine, removed the 500GB drive and inserted a spare 200GB drive formatted with one NTFS partition.
6. I booted using the Winpe disk
7. I invoked CB
8. I chose Restore, then I navigated to the backup on the external USB drive and CB seemed ok with it. The three items from step 1 were checked for restoring them.
9. I was given three options for destination: Disk 0 (the new 200G HD), Disk 1 (my external USB drive), Disk 2 (the USB flash drive containing WinPe).
10. I chose Disk 0 and proceeded with the Restore.
11. I received a warning regarding different partition structures and MBR and then CB proceeded with the restoration process that completed successfully.
12. I then used Diskpart and navigated to Disk 0; it had one C: partition with no data in it, and of course it was not bootable.

What did I do wrong?  Did I perform the wrong type of backup? Am I supposed to prep somehow the replacement drive?

Thanks for reading this long post, but I wanted to present a picture of the process as complete as possible.

ndastar

Offline Emanuel Sescu

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 2171
  • Emanuel Sescu
Re: Failure to Restore System Partition
« Reply #1 on: February 14, 2012, 03:52:45 AM »
9. I was given three options for destination: Disk 0 (the new 200G HD), Disk 1 (my external USB drive), Disk 2 (the USB flash drive containing WinPe).

The target of the restore operation must be selected for each item in backup.
To view exactly where each item (Track0 and MBR, system reserved , C: drive) will be restored, you can click on each of them to be sure.

You selected "Disk 0" as target for restore only for Track0 and MBR, but it's unclear where system reserved and C: drive where restored.
In this situation, the recommended way to restore is to first restore only Track0 and MBR, for the original partition table to be created, then restore the system reserved and C: to the newly created partition table.

Since track 0 and MBR was already restored, you can now proceed to restore the System Reserved drive and C: drive .

Thanks

Edit: Typo fixed.
« Last Edit: February 14, 2012, 03:57:46 AM by Emanuel Sescu »
----
Regards,

Emanuel Sescu
Follow Me

Offline Tudor Postolache

  • Comodo Loves me
  • ****
  • Posts: 100
Re: Failure to Restore System Partition
« Reply #2 on: February 14, 2012, 04:02:21 AM »
Hello ndastar,

It should be something like this:



Offline ndastar

  • Newbie
  • *
  • Posts: 21
Re: Failure to Restore System Partition
« Reply #3 on: February 15, 2012, 03:34:50 AM »
The following relate to Emanuel's suggestions:

"In this situation, the recommended way to restore is to first restore only Track0 and MBR, for the original partition table to be created, then restore the system reserved and C: to the newly created partition table"

1. The program will not allow me to just restore the system reserved and C: without having selected the Track0 as well. If only these two restores are selected I get the error message: "Nothing Selected to restore".

2. You say above to restore the system reserved and C: to the "newly created partition table".  How do you do this? The only option I get is C:\(186.3 GB)  which is my new 200GB drive.

3. So, i set up the restore as:  a) Track0 and MBR --> Disk0 (186.3 GB),  b) (100MB) system reserved --> C:\(186.3 GB), and c) C:\ (59.96 GB) C --> C:\(186.3 GB).

4. It run for about 5 minutes and the result was an "Raw", unformatted 186.3 GB volume.

Is this process documented any place? and tested? or am I wasting my time?
Why can't I say "Restore the system backup xxxx located at this source to Disk-n" ?

Regards,
ndastar

Offline Tudor Postolache

  • Comodo Loves me
  • ****
  • Posts: 100
Re: Failure to Restore System Partition
« Reply #4 on: February 15, 2012, 09:28:09 AM »
Hello,

The way you selected the restore destinations for all the three items (Track0 and MBR, System Reserved and C:) shouldn't even be valid as you selected the same destination for 'System Reserved' and 'C:' also.

If you un-check the 'System Reserved'and 'C:' drives from the 'Select Items to Restore' tree and leave only 'Track0 and MBR' checked and with a destination set you should be able to restore just that.

If you say that your new 200 GB hard drive has only one partition set up you will not be able to restore both 'System Reserved' and 'C:' because there wouldn't be separate destinations for both to be restored on.

That is why you should restore the 'Track0 and MBR' first to recreate the 'old' partition layout. After that you will be able to restore 'System Reserved' and 'C:' on their respective destinations.

Valid destinations for "Track0 and MBR' backups are disks(Disk 0 in your case).On the other hand, partition backups('System Reserved' and 'C:' in your case) must have separate existing partitions as restoration destinations.
« Last Edit: February 15, 2012, 09:32:09 AM by Tudor Postolache »

Offline ndastar

  • Newbie
  • *
  • Posts: 21
Re: Failure to Restore System Partition
« Reply #5 on: February 15, 2012, 03:33:16 PM »
Thank you. 

So this is what I did and the results.
1. As suggested, I first restored Track0 and MBR to Disk0 (it took 15 minutes. Does this sound right?)
2. I then went to diskpart and created two new partitions: a 100MB System Reserved and a C: (approximately the same size as the one in the backup)
3. I then formatted both as primary with NTFS.
4. After that I used CB (from WinPE) and restored System Reserved and C: to their new locations.
5. The contents on the new C: seemed ok, however, the "new" disk was NOT bootable.
6. I boot up with Windows emergency disk,and after almost an hour ii made the disk bootable.

Is this how is supposed to happen?

Is it possible to post recommended step-by-step instructions on how to restore a system disk backup to a new drive (assuming that old drive is dead) so that one has a workable Win environment again.  Please bear in mind that I am not a Microsoft or Intel software engineer and a lot of this terminology is "Greek" to me.

Thank you
ndastar

Offline Emanuel Sescu

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 2171
  • Emanuel Sescu
Re: Failure to Restore System Partition
« Reply #6 on: February 16, 2012, 08:44:17 AM »
1. As suggested, I first restored Track0 and MBR to Disk0 (it took 15 minutes. Does this sound right?)
It usually takes no more than a few seconds, since the track0 and MBR has ~32KB size.

2. I then went to diskpart and created two new partitions: a 100MB System Reserved and a C: (approximately the same size as the one in the backup)
3. I then formatted both as primary with NTFS.
4. After that I used CB (from WinPE) and restored System Reserved and C: to their new locations.
5. The contents on the new C: seemed ok, however, the "new" disk was NOT bootable.
6. I boot up with Windows emergency disk,and after almost an hour ii made the disk bootable.

Is this how is supposed to happen?

The steps you took are ok.
When the partitions are manually created, the offset on disk might not correspond with the original offset so, this is why you needed to run Windows emergency disk.
The next version (CB 4.1) will automatically try to fix this problem when restoring.

Thanks
----
Regards,

Emanuel Sescu
Follow Me

Offline ndastar

  • Newbie
  • *
  • Posts: 21
Re: Failure to Restore System Partition
« Reply #7 on: February 16, 2012, 09:56:34 AM »
ok, thanks

Do you have an estimated target date for 4.1?


Regards,
ndastar

Offline Emanuel Sescu

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 2171
  • Emanuel Sescu
Re: Failure to Restore System Partition
« Reply #8 on: February 20, 2012, 08:14:11 AM »
Do you have an estimated target date for 4.1?
A BETA will be available soon.
The final release will most likely be out by the end of next month.

Thanks
----
Regards,

Emanuel Sescu
Follow Me

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek