Author Topic: SOLVED! Firewall Blocking HippoVNC even though added to Trusted  (Read 4804 times)

Offline SharoneyP

  • Newbie
  • *
  • Posts: 12
I'm trying to use an app on my iPod called Hippo Remote Lite. It will only work when I disable the firewall.

I've added to .exe to Trusted files, and tried running Comodo firewall in Training Mode but nothing works.

The minute I disable the firewall, though, everything works fine.

Any ideas? The app tech support is unfamiliar with Comodo.

Thanks,
Sharon
« Last Edit: April 27, 2012, 04:59:18 PM by SharoneyP »

Offline Radaghast

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 4068
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #1 on: April 27, 2012, 12:39:28 AM »
Depending on your settings, you may need to add a Global firewall rule to allow the protocol and port used by HippoVNV. This is in a addition to the application rule you've already created.
“Don’t worry if it doesn’t work right. If everything did, you’d be out of a job.”

Offline SharoneyP

  • Newbie
  • *
  • Posts: 12
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #2 on: April 27, 2012, 01:31:19 AM »
Thank you very much for your reply. Unfortunately, you've gone way beyond my skill level.

I checked some settings and see number for incoming ports, main and http, but I've no idea what to do with it.

I tried to attache a screenshot of the settings dialog with the actual data redacted, but it wouldn't work so I just included a link to it below. Can you tell me how to set up the global rule using this information? (I'll just plug in the port number(s))

https://picasaweb.google.com/lh/photo/kXJO6VBK2kFATEbJa-RJu9i3e98TGlXYkjnH13p3zw0?feat=directlink

Thanks, regardless!
Sharon

Offline Radaghast

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 4068
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #3 on: April 27, 2012, 02:38:16 AM »
Thank you very much for your reply. Unfortunately, you've gone way beyond my skill level.

I checked some settings and see number for incoming ports, main and http, but I've no idea what to do with it.

I tried to attache a screenshot of the settings dialog with the actual data redacted, but it wouldn't work so I just included a link to it below. Can you tell me how to set up the global rule using this information? (I'll just plug in the port number(s))

https://picasaweb.google.com/lh/photo/kXJO6VBK2kFATEbJa-RJu9i3e98TGlXYkjnH13p3zw0?feat=directlink

Thanks, regardless!
Sharon

It looks like HippoVNC is a fairly standard VNC client, as such the rules needed will be the same as virtually any other VNC application. As I said earlier, depending on your settings, you may need both Application and Global rules. Here's an idea for how you can create these.

First the Global rule:

1. Open CIS/Network Security Policy/Global Rules
2. Select Add
3. Complete the details:

Action - Allow and log
Protocol - TCP
Direction - In
Source Address - Any or the IP address of your i* device
Source Port - Any
Destination Port - 5900

4. Select Apply
5. Make sure there are no 'block' rules above this.

Now for the Application Rule

1. Open CIS/Network Security Policy/Application Rules
2. Select Add
3. Complete the details:

Application Name - WinVNC.exe
Action - Allow
Protocol - TCP
Direction - In
Source Address - Any or the IP address of your i* device
Destination address - ANY
Source Port - Any
Destination Port - 5900

If you need to use HTTP connections, you can add port 5800 to the destination port for both Global and Application rules.
“Don’t worry if it doesn’t work right. If everything did, you’d be out of a job.”

Offline SharoneyP

  • Newbie
  • *
  • Posts: 12
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #4 on: April 27, 2012, 11:57:52 AM »
Thank you very much for the detailed walkthrough!

Unfortunately, it's still not working. The only thing I couldn't figure out how to do from your instructions was set the http: destination port. And, I'm hoping that's the last problem because it is indeed specified as 5800 in the WinVNC dialog.

My  options  for destination port are:
  • Select a single port - this is what I used to set it to 5900
  • Select a port range - thinking this isn't right
  • Select a set of ports - here I'm offered a choice of http:, Pop3, or privileged ports. But, when I then select http I can't specify a particular port number
  • Any port

Do I need to set a second rule with everything the same except the destination port? For both global and application, I'm guessing. Sure I'm missing something obvious, but I'm a bit dazed at this point. :-)

Thanks again for your expert help,
Sharon

Offline Radaghast

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 4068
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #5 on: April 27, 2012, 03:30:35 PM »
You could add a second rule but it's probably easier to create your own Port Set that includes ports 5800 and 5900. Once done, the new port set can be selected from within the rule creation dialogue.
“Don’t worry if it doesn’t work right. If everything did, you’d be out of a job.”

Offline SharoneyP

  • Newbie
  • *
  • Posts: 12
Re: Firewall Blocking HippoVNC even though added to Trusted
« Reply #6 on: April 27, 2012, 04:57:37 PM »
Wow, you are indisputably the absolute best, it worked! Honestly, I thought it was a lost cause.

Thanks, not only for your expertise but for the patient and measured way in which you applied it. A virtual model of forum support.

Wow, again,
Sharon

Offline Radaghast

  • Star Group
  • Comodo's Hero
  • *****
  • Posts: 4068
Re: SOLVED! Firewall Blocking HippoVNC even though added to Trusted
« Reply #7 on: April 28, 2012, 12:13:39 AM »
 Thank you, you're most welcome.
“Don’t worry if it doesn’t work right. If everything did, you’d be out of a job.”

Offline nova2012

  • Newbie
  • *
  • Posts: 1
Re: SOLVED! Firewall Blocking HippoVNC even though added to Trusted
« Reply #8 on: November 19, 2012, 10:53:49 PM »
  hi guys!!
i have a problem using remote control ( free version), i have Sony vaio laptop F series, and im trying to use hippo vnc but i does not connect at all. on my iPod screen the app shows the name of my laptop but i could not connect. at first i thought it is because of my firewall so i turned it off, but i had the same result. even i tried to make a few changes on my network and sharing center but i still have the same issue. to verify that the issue is not from my network or router i tried the app on my roommate laptop who is sharing the internet connection with me and it worked fine on his Asus laptop.

i really don't know what is the problem, if you can help me guys i would appreciate it.

Offline EricJH

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 18658
Re: SOLVED! Firewall Blocking HippoVNC even though added to Trusted
« Reply #9 on: November 23, 2012, 07:56:49 PM »
Do the solutions by laserfan bring a solution for you?

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek