Author Topic: [Merged]Firewall appears to be blocking iTunes 10  (Read 67530 times)

Offline kahhoek

  • Newbie
  • *
  • Posts: 6
[Merged]Firewall appears to be blocking iTunes 10
« on: September 07, 2010, 11:53:00 AM »
When Comodo firewall is enabled and I start iTunes, iTunes will not detect any remote speakers using it's "Airtunes" + Airport Express functionality. If I disable Comodo firewall completely before starting iTunes, the airtunes functionality appears and I can utilise it.

Airtunes is a local network service that streams music to a client connected to my network. It does not in any way direct traffic to outside the local network.

http://support.apple.com/kb/TA21543 Suggests that UDP Port 5353 is required to be open. But even if I open this port I still cannot access "airtunes" with Comodo on. I have even tried adding a rule to allow any connection in/out from iTunes and the related Bonjour service. Comodo does not even pop up an alert with alert frequency set to "Very High" which could help by telling me what it's blocking. Nothing is in the firewall events either. All I can gather is that Comodo is still blocking local connections between iTunes and the Airport Express even though I have added a rule.
« Last Edit: February 01, 2011, 04:53:47 AM by Jacob »

Online EricJH

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 18713
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #1 on: September 07, 2010, 07:54:58 PM »
You need to create a rule in Global Rules to open a port.

Read the following tutorial I made. Substitute the port numbers and protocol for your situation.

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start --> Run --> cmd --> enter --> a black box will show up and enter the following --> ipconfig /all  (notice the space before /all) --> enter --> now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall --> Advanced --> Network Security policy --> Global Rules --> Add --> fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port 

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply --> Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules --> Ok.

Offline kahhoek

  • Newbie
  • *
  • Posts: 6
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #2 on: September 08, 2010, 01:53:59 AM »
Hmmm that seems to have fixed the problem on my laptop - i'll keep monitoring as sometimes the feature still doesnt show up..  I'm just curious though, as this is a connection between two clients in my local network wouldnt the Global Rules "Allow all outgoing requests if the target is in local network" and "Allow all incoming requests if the sender is in local network" mean that I do not need to open up any specific port for the application?

Now I have a similar problem except on my Desktop.
The issuewith my desktop though isn't fixed by the above. Airtunes/Airplay via iTunes will not show up in iTunes at all if Comodo is installed. Even if I set Antvirus, Firewall and Defense+ to Disabled on my deskop, or use the above suggestion to open a port I cannot stream music via Airtunes on my Desktop.
However, what's really weird is if I uninstall Comodo completely the option will then show up in iTunes. If I reinstall Comodo again and have the firewall off the option dissapears. Any ideas on that one?

Edit - Just tried again. Uninstall Comodo. Reboot. Airtunes option shows up in iTunes.
Reinstall Comodo. Reboot. Firewall On. Airtunes option does not show up in iTunes. Turn Firewall off. Reboot. Still no airtunes option.
This is all on my desktop and no longer on my laptop which was the subject of my initial post.
« Last Edit: September 08, 2010, 02:42:52 AM by kahhoek »

Online EricJH

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 18713
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #3 on: September 08, 2010, 06:11:08 PM »
Hmmm that seems to have fixed the problem on my laptop - i'll keep monitoring as sometimes the feature still doesnt show up..  I'm just curious though, as this is a connection between two clients in my local network wouldnt the Global Rules "Allow all outgoing requests if the target is in local network" and "Allow all incoming requests if the sender is in local network" mean that I do not need to open up any specific port for the application?
If you are making your local network trusted the open port rule in Global Rules will not be necessary.

However you still need to make sure the application rule will allow incoming traffic. You can make it Trusted and it will accept all incoming traffic at all ports and protocols. Or make a custom rule which allows incoming traffic only at UPD port 5353.

Quote
Now I have a similar problem except on my Desktop.
The issuewith my desktop though isn't fixed by the above. Airtunes/Airplay via iTunes will not show up in iTunes at all if Comodo is installed. Even if I set Antvirus, Firewall and Defense+ to Disabled on my deskop, or use the above suggestion to open a port I cannot stream music via Airtunes on my Desktop.
However, what's really weird is if I uninstall Comodo completely the option will then show up in iTunes. If I reinstall Comodo again and have the firewall off the option dissapears. Any ideas on that one?

Edit - Just tried again. Uninstall Comodo. Reboot. Airtunes option shows up in iTunes.
Reinstall Comodo. Reboot. Firewall On. Airtunes option does not show up in iTunes. Turn Firewall off. Reboot. Still no airtunes option.
This is all on my desktop and no longer on my laptop which was the subject of my initial post.
What version of CIS are you using on your desktop? When using v4 can you see if any iTunes files are being sandboxed? Look in My Pending Files and when there select them all and move them to My Own Safe Files. Then reboot the computer and try again.

Offline kahhoek

  • Newbie
  • *
  • Posts: 6
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #4 on: September 09, 2010, 12:56:15 AM »
If you are making your local network trusted the open port rule in Global Rules will not be necessary.

However you still need to make sure the application rule will allow incoming traffic. You can make it Trusted and it will accept all incoming traffic at all ports and protocols. Or make a custom rule which allows incoming traffic only at UPD port 5353.
What version of CIS are you using on your desktop? When using v4 can you see if any iTunes files are being sandboxed? Look in My Pending Files and when there select them all and move them to My Own Safe Files. Then reboot the computer and try again.

Yes local network is trusted. I do file sharing, printer sharing and have a local web server so I know local connections work fine. I did make it trusted but it appears to still not provide me the airtunes option 100% of the time.

CIS 4.1 is running on my Desktop. Sandboxing is disabled I prefer not to use it. Disabling sandboxing is the first thing I do after installing CIS. And no, iTunes on my desktop still does not give me any option to do airtunes streaming.

Offline kahhoek

  • Newbie
  • *
  • Posts: 6
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #5 on: September 09, 2010, 02:13:56 AM »
Whats really strange is on my Desktop i've just installed Airfoil. Airfoil is a 3rd party application which has the same functionality to iTunes in that it can connect to an Airtunes speaker and stream music to it.
Airfoil picks up the Airtunes speaker immediately without me manually doing anything in Comodo. Even when Airfoil picks up the Airtunes speaker, if I then close it and start iTunes. iTunes will not pick up the Airtunes speaker. I have checked the obvious in iTunes and iTunes is searching the network for the speakers.

Online EricJH

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 18713
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #6 on: September 09, 2010, 12:18:49 PM »
Try "Activate Defense+ permanently (Requires a system restart)" and see it that helps or not. This can be done in Defense + --> Advanced --> Computer Security Policy.

Offline kahhoek

  • Newbie
  • *
  • Posts: 6
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #7 on: September 16, 2010, 12:50:43 AM »
Nah that didn't work. Though it appears with Comodo installed after a long period of time iTunes will detect the speaker. By that I mean anytime over one hour.. Sometimes it doesn't detect it at all. It's very strange.
No Comodo means instant detection.

Offline sjhande

  • Newbie
  • *
  • Posts: 2
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #8 on: October 02, 2010, 05:47:53 AM »
Can I tag along with this one please as I am having exactly the same issue. Uninstall Comodo - detects the speaker and can use. Comodo on/ installed - doesnt show

Online EricJH

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 18713
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #9 on: October 02, 2010, 01:26:37 PM »
Kahlhoek en sjhande. Does this also happen on v5.

As I was rereading this topic I wrote
Quote
However you still need to make sure the application rule will allow incoming traffic. You can make it [Trusted and it will accept all incoming traffic at all ports and protocols.
. When I wrote Trusted I meant Trusted Application.

Kahlhoek can you confirm you made the program Trusted Application?

The reason for asking is because in v5 My Own Trusted Files is now called Trusted Files. My way of paraphrasing may cause confusion.

Offline sjhande

  • Newbie
  • *
  • Posts: 2
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #10 on: October 03, 2010, 07:03:20 AM »
Can confirm its a trusted application.
Also noted I can get the external speakers to play via Airfoil and Itunes.

Offline jose62664

  • Newbie
  • *
  • Posts: 1
Re: Firewall appears to be blocking iTunes 10 Airplay
« Reply #11 on: October 09, 2010, 08:06:01 PM »
sjhande,

it's been a week, how is the Airfoil working. Have you had any interruptions to your airport express?

Offline andyo

  • Newbie
  • *
  • Posts: 11
Itunes sharing getting blocked even when firewall disabled
« Reply #12 on: November 25, 2010, 06:46:08 AM »
Hi

I've searched here and on google for hours, but I can't see a fix for this. There are several posts with a problem similar than mine here, but went unresolved, or its resolutions don't apply in my case.

Using Itunes 10.1 and Comodo FW 5.0.16352.1142 (freshly downloaded and installed, default settings except for the rules you see on the screenshots), Itunes doesn't wanna discover shared itunes libraries from another computer. Both PCs (HP DV5t laptop and a desktop) are running Windows 7 64-bit. It seems anything related with Itunes that uses Bonjour is not working well (the ipod touch remote app doesn't discover the libraries either).

I have put all the relevant applications as trusted, and even have the firewall disabled. I don't get anything on the log or event viewer, even though I've set all blocking rules to log.

The moment I uninstall Comodo, Itunes and Bonjour work perfectly. I have uninstalled/installed Comodo firewall about 5 times, and I've also tried other free firewalls like ZoneAlarm (sucks), and a couple others whose names I forget, but none are as powerful as Comodo (don't let me filter by IP at least).

Any ideas would be appreciated!

Offline Matty_R

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 2527
  • How long is a piece of string?
Re: Itunes sharing getting blocked even when firewall disabled
« Reply #13 on: November 25, 2010, 08:09:26 AM »
Hey andyo, i may not be much help as i don`t use itunes or the stuff that goes with it, maybe someone who does will be better finding the missing link!

Anyway i did notice that you didn`t have an rules for svchost which may be needed for the Bonjour service. Try setting up a rule similar to that for System, maybe then tweaking it if it works.

Also maybe set the ApplemobiledeviceService as Trusted.

One other possible thing to try is use the Stealth Ports Wizard to Alert to Incoming connections (possibly even remove all Global Rules) turn the Firewall up to Custom with the Alert settings Very High then try and connect.
Also try unticking Firewall Behaviour Settings->Advanced->Block Fragmented IP Datagrams (if this does nothing re-tick it)

Sorry i can`t be of more help
A couple of computers :P

Offline andyo

  • Newbie
  • *
  • Posts: 11
Re: Itunes sharing getting blocked even when firewall disabled
« Reply #14 on: November 25, 2010, 12:09:59 PM »
Thanks, I forgot to mention I did try the stealth ports wizard. I tried again with your recommendations, removed all global rules but it's the same.

Also, with the firewall completely disabled, which should let everything through, I still have these problems. It gets fixed only when I uninstall CFP.

I have Defense+ completely disabled, BTW.
« Last Edit: November 25, 2010, 12:11:45 PM by andyo »

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek