Security Products & Services > Firewall Help - CIS

CIS Firewall Blocking my VOIP device (NetTalk DUO)

(1/1)

innovate2000:
Hello, I've been a Comodo CIS user for several years (even before it became CIS) - I say this to demonstrate that I'm not really a noob. My NetTalk device will not work unless the CIS Firewall is disabled. I've set nettalkg.exe, nettalkl.exe and nettalkd.exe (the three exe's associated with the service) as trusted applications (Setting: "Allow All Requests" which should allow all ports (IN/OUT), all protocols (IN/OUT) and all addresses (IN/OUT)) - which SHOULD allow the DUO totally free reign - but it doesn't. It only works when the firewall is disabled - which is really confusing. (The Windows Firewall is already disabled (as I am using the Comodo Suite)). Shouldn't allow all access pretty much act the same as if the firewall was disabled for this unit? Are there other ideas that I might try? This is really frustrating.

DonZ:
The following is from the netTalk support site. First make sure your problem is not your router. Can you contact netTalk for free setup/configuration support? I would try that first.

If Comodo firewall is the problem, have you been receiving desktop alerts from Comodo? Have you checked your Comodo firewall event logs for blocked entries for anything related to netTalk?

It states below that it uses ports 69, 5060, and ports in the 10000 - 20000 range. I assume those are UDP but not sure.

Common Security Blocks for netTALK
 
ArticleNetworking devices can sometimes block the netTALK from communicating with our infrastructure. You may want to consult the manufacturer of your router in terms of applying a special security setting that would allow for our netTALK TK6000 or DUO device to communicate properly with our infrastructure. The bottom of the e-mail will give possible generic solutions to your issue.
Every time you make a change in the router be sure to power cycle the TK6000 or DUO.

SECURITY INFO:
-Try using a different DNS < Very prevalent with cable internet service providers
++Preferred DNS: 4.2.2.2
++Alternate DNS: 4.2.2.1
-You may need to put the TK on the DMZ.
-You may need to lower restriction on your SPI firewall.
-You may need to change a setting on the router called SIP ALG (if enabled, try disabling. If Disabled, try enabling).
-You may need to change a setting from UDP restricted to UDP independent.
-You may need to unblock the following ports. Try port triggering first, than try port forwarding to the TK/DUO's IP
: 69
: 5060
: Port range: 10000-20000
-Check to see if your router has the latest firmware installed.
-Finally if all else fails, you can attempt to connect the TK6000 or DUO in another environment (a friend's/relative's/neighbor's) home to see if it can grab the initial configuration in their home.

Navigation

[0] Message Index

Go to full version
Seo4Smf 2.0 © SmfMod.Com Smf Destek