Author Topic: Alert on localhost connections?  (Read 27378 times)

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #15 on: December 18, 2007, 02:54:59 PM »
bump

Toggie

  • Guest
Re: Alert on localhost connections?
« Reply #16 on: December 18, 2007, 04:04:38 PM »
Have you upgraded to 3.0.14.276 yet? It now directly supports loopback networking in the firewall. However, it doesn't appear possible, yet, to create rules/alerts for inbound loopback networking.

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #17 on: December 21, 2007, 11:31:07 AM »
Still not working as I would like it to.

Offline gibran

  • Average User
  • Comodo's Hero
  • *****
  • Posts: 5056
  • A bad workman always blames his tools
Re: Alert on localhost connections?
« Reply #18 on: December 21, 2007, 05:29:01 PM »
Still not working as I would like it to.

Please would you mind to describe the actual beaviour and the desired one?
"In the beginning the Universe was created. This has made a lot of people very angry and has been widely regarded as a bad move."- Douglas Adams

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #19 on: January 18, 2008, 11:58:31 AM »
Whenever ANY program is trying to open a connection, I want an alert. Even though the connections are only localhost. This is not the case with comodo now.

Maybe some don't want it to, but I do. Make it an option.

sded

  • Guest
Re: Alert on localhost connections?
« Reply #20 on: January 18, 2008, 12:14:13 PM »
What version of CFP3 are you currently using?  Do you have a rule "allow access to loopback zone" under your predefined policies for web browser, email client, other applications that might access localhost?  Try editing by clicking the "log" function see if the connections are logged.  Works for me, but seems a bit erratic-will check a little further and play with my proxies a bit.
« Last Edit: January 18, 2008, 04:07:10 PM by sded »

sded

  • Guest
Re: Alert on localhost connections?
« Reply #21 on: January 18, 2008, 04:24:33 PM »
OK, some further observations of some of the alert characteristics.  You need to try it with your particular applications of concern.  But you can generate alerts on localhost connections.
1) It looks like applications that make multiple localhost connections in a single run may not log them all.
2) With a proxy (like Avast!) in the connection path, what gets logged is the proxy address, not the destination path in the application.  (For Avast! that means the log will show 12110 and 12080 as the destination ports in local host).
3) Loopback to loopback stuff doesn't seem to get logged at all (Avast! to Stunnel in my case).

I have not tried to be exhaustive, but it looks like a place to start is by adding the log to whatever loopback you already have.  And the proxy ports all need to be part of the allowed ports.

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #22 on: January 22, 2008, 02:32:36 PM »
I don't see any logs or alerts. I don't want logs really, I want alerts.
X is trying to connect to...

The application is not allowed.

I used the second public release, don't remember version number.

The big disappointment is that every other firewall I've tried DOES alert me. comodo doesn't.
I tried enabling highest security, remove all apps in firewall list, no change.


sded

  • Guest
Re: Alert on localhost connections?
« Reply #23 on: January 22, 2008, 02:48:18 PM »
You should be using version 3.0.15.277, which had a number of fixes from the initial public releases.  Are you using custom policy mode with very high alert settings for the firewall?  And have you set D+ to paranoid mode and set access rights for loopback networking to block?

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #24 on: January 22, 2008, 04:20:23 PM »
I "USED" it, I uninstalled it due to this...

Due to the releasenotes .277 has nothing to do with this problem, I had the previous (275?) one.
I had anything on default, and then topped al settings to the highest possible.

Yes, I also tried blocking localhost connections, and this had no effect whatsoever.

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #25 on: January 31, 2008, 05:14:15 PM »
Any more information?
Will it be changed in future releases?

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #26 on: February 04, 2008, 04:27:48 PM »
Nobody knows ?

I thought that  (R)
but if comodo seems to be the only firewall not doing this, it would mean that comodo  :-TD

sded

  • Guest
Re: Alert on localhost connections?
« Reply #27 on: February 04, 2008, 04:36:00 PM »
Sorry; don't know what Comodos plans are- I don't work for them.  You might try posting in the feedback/comments section where Melih and some of the developers might read it.  Or I can move this thread for you.   You can try changing the block rules discussed in my previous post to "ask" and see if you get a popup for them-"ask" does not work in my system, so can't evaluate it.  Also new version 3.0.16.295 is out, but not change log.  You may want to try that also.

Offline amews_aj

  • Comodo Family Member
  • ***
  • Posts: 68
Re: Alert on localhost connections?
« Reply #28 on: February 04, 2008, 04:39:07 PM »
It did not work when I tried making ask rules.
I would like to see changelog before upgrading.
Please move this topic.

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3309
Re: Alert on localhost connections?
« Reply #29 on: February 04, 2008, 04:50:42 PM »
It did not work when I tried making ask rules.
I would like to see changelog before upgrading.
Please move this topic.

Can you tell me how you test please? You should have received outbound loopback connection alerts from the firewall.

Egemen

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek