Author Topic: CFP_Setup_3.0.23.364_XP_Vista_x32 - High CPU Load on process 100% on 1 core  (Read 15359 times)

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Vista SP1, CFP 3.0.23.364, upgraded from CFP_Setup_3.0.22.349_XP_Vista_x32.
I have at least 2 programs going to 100% cpu on one core.
One is a batch file, the other one is ClamWIN update (freshclam.exe).

I put process monitor on it and both files end with the same query. (QueryNameInformationFile) on guard32.dll

Filespecs of c:\windows\system32\guard32.dll = 3.0.23.357

I tried to disable Defence+ but that didn't help (after a reboot).

I uninstalled the CFP and the problem is gone.

Please advise

Regards,
Ronny



[attachment deleted by admin]
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline hv007

  • Newbie
  • *
  • Posts: 2
I made similar experiences with XP /SP2. After the latest update I got processes which blocked one CPU an never ended.
For example installation of lenovos update service, suns java jre etc. failed as during the installation process one process just never ended.
Just try "java -fullversion" in a dos-box - it will never end but block one CPU.
The only solution was to deinstall Comodos Firewall - disabling did not solve the problem.

with kind regards
harald

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Bug is still present in version: CFP_Setup_3.0.24.368_XP_Vista_x32
I've done a complete uninstall, cleanup, reboot. Put up a fresh install of 3.0.24 it doesn't fix the problem.

I've done some testing and i can reproduce it.

First i start a command box, when i type "exit" the first core goes 100% util.
I have to kill the process to get the cpu back.

I have run Autoruns, and disabled the Appinit_dll guard32.dll

If i start a command box it works normal no cpu load and exit normal, no reboot or what so ever, on the fly.
If i put the Appinit_dll /guard32.dll back to enabled, the problem reappears.
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Can someone tell me if this is going to be fixed ?
Do you need more information ?
What can i do to help ?
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline sbpir92i

  • Comodo Family Member
  • ***
  • Posts: 72
this is normal
 look cProgram Files\Comodo\Firewall\Repair
look guard32.dll  = 3.0.23.357


Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
I don't get it ?
It's normal that a closing process via a call to AppInit guard32.dll consumes 100% cpu never ending until you kill the specific process ?
I think that's not normal.

Info: Also the process mcbuilder.exe goes 100% and never returns until i kill it.
And this is a process that's started by vista on boot, so now i have to manualy kill this process everytime i start my machine.
« Last Edit: May 29, 2008, 02:14:06 PM by rhgtyink »
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline jtabos

  • Computer Security Testing Group
  • Newbie
  • *****
  • Posts: 12
Right, the mcbuilder was the other process alongside the cvtres sucking the cpu; I had to kill them manually also.
As I said in this thread, the old 3.0.21.329 version is working fine here.
http://forums.comodo.com/bug_reports/cvtresexe_netframework_99-t23317.0.html;msg164524#msg164524
« Last Edit: May 29, 2008, 02:56:46 PM by jtabos »

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
As posted in other reports it looks like a conflict with CMF, if i put cmd.exe and mcbuilder.exe in the CMF 2.0.4.20 exclusion list than the problem disappears. CPF version 3.0.25.378.

Remove it from the CMF exclusions and the problem is back.
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Can someone tell me if this will be fixed in the next release ?
And maybe when the next release is to be expected ?

 (R)
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline nikoden

  • Newbie
  • *
  • Posts: 22
  • QA TL
Ronny, I understand that you have CMF and CFP installed on same machine.
So, problem becomes reproducible when both are running and application is not in CMF exclude list, right?

Let us check it.

Thanks for the feedback.

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Hi Nikoden,

That's right i have 2 ways of workarounds, one is to put the file in the CMF exclusion list.
The other is to use Autoruns from Sysinternals and "unselect" Guard32.dll from the Tab "AppInit".
But i prefer to use the first one of course.

Regards,
Ronny



[attachment deleted by admin]
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

Offline Ronny

  • Retired - Product Translator
  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 13551
  • Retired - Volunteer Moderator
Hello Nikoden,

Any news on this, appears the problem also appears on systems with CMF and Subelt VIPRE see here
Retired - Volunteer Moderator
Any concerns? Please send me a PM or review the Forum Policy -  update Jan 3rd 2013!

 

Free Endpoint Protection
Seo4Smf 2.0 © SmfMod.Com Smf Destek