Author Topic: Failed ShieldsUp!, ping reply received.[CLOSED]  (Read 3256 times)

Offline FireBreather

  • Newbie
  • *
  • Posts: 4
Failed ShieldsUp!, ping reply received.[CLOSED]
« on: October 26, 2007, 11:17:30 PM »
"A PING REPLY (ICMP Echo) WAS RECEIVED."
How does one go about remedying this?  Thx!  =o)

Offline panic

  • Global Moderator
  • Comodo's Hero
  • *****
  • Posts: 11455
  • Linux is free only if your time is worthless.;-)
Re: Failed ShieldsUp!, ping reply received.
« Reply #1 on: October 27, 2007, 12:24:59 AM »
Double check the IP address of your PC against the IP address that ShieldsUp is testing. If you're behind a router (or a modem that acts like one), then 99 times out fo 100, it is the device that is responding to the ShieldsUp test, not your PC.

To test your PC from behind a router, you need to port forward all the relevant ports on the router to the internal IP address of the PC you want to test.

Hope this helps,
Ewen :-)
As your mums would say, "If you can't play nice with all the other kiddies, go home".
All users are asked to please read and abide by the  Comodo Forum Policy.
If you can't conform, don't use the forum.

Offline MiguelT

  • Newbie
  • *
  • Posts: 12
Re: Failed ShieldsUp!, ping reply received.
« Reply #2 on: October 27, 2007, 01:15:47 PM »
I have a same problem, i keep failing that Shields Up test. My firewall replies that ping request. I have no router and my external IP address is the one that they scan.

This worries me, any advice how to cure this problem?
Miguel Täystuho...

Offline Ragwing

  • Comodo's Hero
  • *****
  • Posts: 3498
Re: Failed ShieldsUp!, ping reply received.
« Reply #3 on: October 27, 2007, 01:18:08 PM »
I have a same problem, i keep failing that Shields Up test. My firewall replies that ping request. I have no router and my external IP address is the one that they scan.

This worries me, any advice how to cure this problem?

Have you made any changes to the network rules?


Ragwing

Offline marcel4

  • Newbie
  • *
  • Posts: 19
Re: Failed ShieldsUp!, ping reply received.
« Reply #4 on: October 27, 2007, 04:28:41 PM »
I had it too but i think the problem is when i installed commodo firewall i checked i would see firewall alerts for incoming connections because i use utorrent when i blocked all incoming connections and made a rule for utorrent everything is ok.

Offline FireBreather

  • Newbie
  • *
  • Posts: 4
PS to: Failed ShieldsUp!, ping reply received.
« Reply #5 on: October 27, 2007, 06:13:22 PM »
<< "A PING REPLY (ICMP Echo) WAS RECEIVED."
How does one go about remedying this?  Thx!  =o) >>

To clarify: No previous ßeta version has failed (and I've run them all) and I have *not* changed any settings.  If, I turn on the Windows Firewall, my system 'passes' ShieldsUp! 100%.  Ideas anyone?  ;-/

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3317
Re: PS to: Failed ShieldsUp!, ping reply received.
« Reply #6 on: October 27, 2007, 06:52:41 PM »
<< "A PING REPLY (ICMP Echo) WAS RECEIVED."
How does one go about remedying this?  Thx!  =o) >>

To clarify: No previous ßeta version has failed (and I've run them all) and I have *not* changed any settings.  If, I turn on the Windows Firewall, my system 'passes' ShieldsUp! 100%.  Ideas anyone?  ;-/

Can you please post us the screenshot of your Global Rules in network Security Policy?

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3317
Re: Failed ShieldsUp!, ping reply received.
« Reply #7 on: October 27, 2007, 07:05:52 PM »
Never mind my previosu message.

Yes I have verified the issue. This is a bug when P2P friendly configuration is selected.

To remediate the problem : Go to Network Security->Global Rules and double click on the rule "BLOCK ICMP IN FROM ANY TO ANY WHERE ICMP MESSAGE IS ECHO REQUEST".

Go to ICMP Details page and Select "Any" in the combobox. This should do the work until we fix it.


Sorry ffor the inconvenience,
Egemen


Offline antcodd

  • Newbie
  • *
  • Posts: 10
Re: Failed ShieldsUp!, ping reply received.
« Reply #8 on: October 27, 2007, 08:48:34 PM »
I didnt have this problem (I think the router specifically blocks ping requests even as DMZ), but according to ShieldsUP! my computer is exposing all the NetBIOS information, shares etc (everything on the file sharing page except it exposes no actual shares) when under the new p2p friendly mode. How do I block specifically file sharing traffic (the blocking all ICMP didn't work). This should definately be the default (otherwise what is the point of having a firewall at all if it is less secure than windows firewall?). I have manually changed the rule to the old block all in rule from previous versions.

Regards,
Anthony

ps: Loving the trusted software vendors feature and new config wizard, that should stop windows update problems once and for all. Is there a way to manually rerun the wizard? At the moment I can see no way of changing to non p2p friendly mode other than manually changing the rule.

Offline egemen

  • Comodo Staff
  • Comodo's Hero
  • *****
  • Posts: 3317
Re: Failed ShieldsUp!, ping reply received.
« Reply #9 on: October 27, 2007, 09:16:33 PM »
I didnt have this problem (I think the router specifically blocks ping requests even as DMZ), but according to ShieldsUP! my computer is exposing all the NetBIOS information, shares etc (everything on the file sharing page except it exposes no actual shares) when under the new p2p friendly mode. How do I block specifically file sharing traffic (the blocking all ICMP didn't work). This should definately be the default (otherwise what is the point of having a firewall at all if it is less secure than windows firewall?). I have manually changed the rule to the old block all in rule from previous versions.

Regards,
Anthony

ps: Loving the trusted software vendors feature and new config wizard, that should stop windows update problems once and for all. Is there a way to manually rerun the wizard? At the moment I can see no way of changing to non p2p friendly mode other than manually changing the rule.

Firewall->Tasks->Stealth Ports Wizard allows you to switch between these modes.

You should be careful while answering the popups. It should have showed you "System is trying to receive a connection from 4.xxxxxxx". This means grc.com site is probing you. Dont alow any application to receive a connection except your P2P applications.

Egemen

Offline MiguelT

  • Newbie
  • *
  • Posts: 12
Re: Failed ShieldsUp!, ping reply received.
« Reply #10 on: October 28, 2007, 12:19:33 AM »

Yes I have verified the issue. This is a bug when P2P friendly configuration is selected.

To remediate the problem : Go to Network Security->Global Rules and double click on the rule "BLOCK ICMP IN FROM ANY TO ANY WHERE ICMP MESSAGE IS ECHO REQUEST".

Go to ICMP Details page and Select "Any" in the combobox. This should do the work until we fix it.




This helped for me! I now pass the Shields Up!

Thank you.
Miguel Täystuho...

Offline antcodd

  • Newbie
  • *
  • Posts: 10
Re: Failed ShieldsUp!, ping reply received.
« Reply #11 on: October 28, 2007, 05:35:04 AM »
Firewall->Tasks->Stealth Ports Wizard allows you to switch between these modes.

You should be careful while answering the popups. It should have showed you "System is trying to receive a connection from 4.xxxxxxx". This means grc.com site is probing you. Dont alow any application to receive a connection except your P2P applications.

Egemen

Thanks for the reply,
I don't remember being asked for the incoming connection and I can't find any rule that allows incoming connections for System or any other application I don't recognize, I even tried creating a rule for System that blocks all traffic (below the network zone rules though) and I tried setting those rules to block too and it still shows me as exposed. Not even high alert level asks. What is the specifc app that does networking? What am I doing wrong lol? :P

 

Seo4Smf 2.0 © SmfMod.Com | Smf Destek